Mycroft in VirtualBox - Ubuntu Problems with Snaps

Hej Guys,
I had real problems setting up Myrcoft using the guide including the VirtualBox/Ubuntu Image.
In short: The installation of Ubuntu did not preceede due to some problems with “snaps” which I honestly did not understand (here is more to that).

So for the simple users as me, who use Linux not that often, I figured a solution to that problem, which is using Debian 10 instead of Ubuntu.
This website helped me a lot.
At the moment I got Mycroft running in a FullDesktop Version. The network-server image I tried is not working, there I have some problem with the audiodriver, if someone has an idea, I am very open for suggestions!

some addition help:
I had to install a few things to get mycroft running smoothly:
in root:
apt-get install sudo //to install the sudo command
gpasswd -a user sudo //to get your user to be allowed to use sudo, somehow visudo didnt work

sudo apt install git // to get git :wink:
and you have to allocate at least 12gb to your virtual hard drive
in the fullimage this should be enough, in the minimal I also had to install pulseaudio, e.g. and apparently the alsa drivers, which I have no real idea how to do that.

hope this helps someone and maybe someone else has an idea how to get the minial image running as well :slight_smile:

What image did you use to create the VM, did I read in the other thread that it was Ubuntu 18.04?

The Ubuntu I had problems with was 19.10 since the guide said it both worked.
The Debian I had problems with was the 10.1 netinstall (approx 300mb).
The full Debian I got it running with is the 10.1 gnome.
Take your pick :slight_smile:

Do you think 18.04 might not have the snaps problems? since I had no real idea what they were, I figured Ubuntu=Ubuntu

@edit: ubuntu 18.04 did complete the installation process without a problem. feel kind of stupid, that I didnt even try before. But only kind of, since now I have again problems with the sound :smiley: which is running more or less smoothly on the debianfulldesktop

Since you are in a VM, what sound card do you have defined for the VM? Is it bound to your main workstation? IE can you play an mp3 or something with mplayer to validate that the sound is working properly outside of the Mycroft application?

I don’t see what version of VirtualBox you were using, although I assume it was the same for both your successful Debian install and the unhappy Ubuntu trials.

The sound may be a virtualbox problem as discussed on the ask ubuntu forum where the installation of pulseaudio for the minimal image is discussed.


thanks for bringing up the topic again. I think it is a settings problem. I opend up the mixer thingy ( i dont remember the command, the one with the not so nice gui, and all the rulers where down. I dont really understand what all the rulers stand for, so I set them all to medim hight, but nothing changed.
@Guyverix i cannot play an mp3 or something. The “record and play” audio test doesnt help either. Honestly I feel a little overwhelmt (or felt, since its been a while) with the settings and the output, since I have really no idea what most of it means, so I would rather have the mic-problem working on my Debian system, which is maybe not the smoothest way but for my purposes and my motivation the best and most helpfull, I guess. If anyone has some input on that, I could focus on the sound problems with the ubuntu when I have some more time on my hands to get into the whole pulse-audio/alsa-mixer stuff :sweat_smile: thanks a lot, though!
and btw, @inallhissteps yes its the same VB all the time. there I just ajusted the volume with the volume bar in the GUI settings and it was done ^^