Wake word not working

I’m a complete novice and trying to learn my way around so far.
I used the troubleshooter page and used “grep avx /proc/cpuinfo” and nothing came up.
Apparently this means it’s incompatible.
My computer is rather old. Is there a way I can get around the incompatibility issue, please?

You can download the source for tensorflow (<1.14.3) and compile it yourself.

Thank you. Is Tensorflow to be used with Precise or instead of?

Precise makes use of tensorflow.

Thank you.
I’ve ran into some problems with Tensorflow. It seems that some of the programs it relies on aren’t available for Ubuntu 20.04.
It’s mostly NVIDIA that’s causing problems.
Is there another way around getting mycroft to wake to voice, please?

You can use pocketsphinx, though I find its performance to be much less all around.

I would considering using a virtual machine with Ubuntu 18.04 on it. I ran into dependency hell trying to use 20, and finally just gave up.

Not sure what platform you’re on, but I have a writeup here that will work across just about any operating system, if you’d like to give it a go.

Brilliant, thank you!
I know just what you mean, I’ve been struggling with the web of dependencies for ages now and I’m close to tearing my hair out.

I’ve got post-it notes all over my monitor frame and a list of dependencies of dependencies of dependencies… it looks like a complicated family tree!
I wiped the hard drive and started over for the 5th time yesterday after it failed to work correctly again so I’ll definitely give this a try!

Yeah man. I feel your pain. VirtualBox running Ubuntu 16.04 saved my brain. It really is as easy as that, plus a few things you need to tweak. It’s in my guide!

What would I do differently if I don’t have Raspberry Pi?

I don’t know how flexible Mycroft is between platforms or if this is possible, but ideally I’d like to have it working on my desktop for the time being, then in future, copy everything to portable devices as and when I acquire them.

Works great on linux on most any platform I’ve tried on (servers, desktops, pi[3/4]).

Well, the guide I referenced is meant to run on basically whatever you want, but I recommend a desktop / laptop. (You can model on a Pi, I’ve done it, but it’s not…fast.) Then you just need to transfer the .net and .params files over to whatever device your Mycroft instance is running on.

Thank you! It’s up and running, almost.
Back to the microphone issue again. I followed these instructions to troubleshoot the sound:


All the tests were working up until I set the default mic for mycroft as it instructed (I followed the instructions step by step). Now the mycroft microphone test is no longer successful. Does anyone know what happened and how to fix it, please?