Update to Neon: my experiences so far

Since learning the basics with the original software that came with my MK2, i have since moved to Neon.
I got a USB-SSD.
Downloaded & installed NEON on it.
Like it so far.

Some questions/observations:

When I did a power off from the touch screen, the back light stayed on, nothing on the screen, fan running high.
I did an update. That installed some new screens and now it goes dark/silent when I ask power off/shutdown.

Since the update, when powered on, the RED leds on the switch on the top are slowly turning.
Any idea how to stop this ?

So far today 5 times it started “babbling” because it seemed to have recognized the trigger word.
There was no TV or Radio on that moment.

1 Like
  1. Sounds like that’s running correctly after the update.

  2. That’s usually a signal that you’ve lost wi-fi / internet connection. You’ve probably got it fixed by now, if not, please tell me more about your internet connection method.

  3. We’re working on trigger word sensitivity. For now, the best solution has been to tell it “change my wakeword to Mycroft”. That wakeword is trained differently, and consequently is less sensitive.

1 Like


Still red all these days!
I have it hooked up to wifi via a static ip address on the router with DHCP.
I have no problems with wifi on any other (IoT) devices.
How can I debug wifi/internet problems ?
I also have an ethernet cable available if needed.

I just changed that. will report if it still triggers.

Thank you for your feedback!

1 Like

Is it able to retrieve answers from Wikipedia, or otherwise indicate that it’s actually online in spite of the red lights?
If so, I bet it’s an issue from your wifi configuration, and if so you could confirm that by switching to ethernet cable and seeing if it goes away. We can then add that to our bug fix list if it can be narrowed down that far. Thanks!

it was not able to check for updates
it was able to tell me weather (and it was accurate, so I guess it needs internet connectivity for that!)
I am logged in over ssh through the wifi connection without issues.
When I plugged in ethernet cable and through the touch screen switched over to ethernet port, the red lights turned green and went off
i was able to update from 23.4.4 to 23 point 4 point 24 alpha 10
it is now able to access wiki

I would like to help debug why neon is pretending to have a problem with wifi vs wired ethernet.
I know enough about linux/networking to help figure it out if you tell me what/how to check it.

Wonderful! Thank you. @NeonDaniel, maybe you have some insight?

after a reboot, the red led’s came back on again.
I erased the wifi setting so I only have wired ethernet available

Run a speed test

Starting a speed test.
Your internet speed is 285 Mbps download and 21 Mbps upload with a ping of 20 ms.
Provided by speedtest.net.

I think that proves internet is alive and accessible.


Search Wikipedia for dogs

I’m checking Wikipedia for dogs
The dog (Canis familiaris or Canis lupus familiaris) is a domesticated descendant
of the wolf

I have both working ipv4 & ipv6:

(venv) neon@neon:~$ host www.wikipedia.net
www.wikipedia.net is an alias for ncredir-lb.wikimedia.org.
ncredir-lb.wikimedia.org has address
ncredir-lb.wikimedia.org has IPv6 address 2620:0:863:ed1a::3

(venv) neon@neon:~$ ping6 -c3 www.wikipedia.net
PING www.wikipedia.net(ncredir-lb.ulsfo.wikimedia.org (2620:0:863:ed1a::3)) 56 data bytes
64 bytes from ncredir-lb.ulsfo.wikimedia.org (2620:0:863:ed1a::3): icmp_seq=1 ttl=55 time=21.4 ms
64 bytes from ncredir-lb.ulsfo.wikimedia.org (2620:0:863:ed1a::3): icmp_seq=2 ttl=55 time=22.7 ms
64 bytes from ncredir-lb.ulsfo.wikimedia.org (2620:0:863:ed1a::3): icmp_seq=3 ttl=55 time=25.2 ms

So why still the red leds ?
Let me know if I can help debug.

That is a strange one… The network checks are defined in ovos-utils and simply run periodically (every minute by default) to determine the current state. If an internet connection test fails, the LED animation runs until a connection event (like wifi-setup) or a passing check… Can you check if you have any issues accessing these default URLs? DNS addresses should ping, and the URLs should return some text.

    "dns_primary": "",
    "dns_secondary": "",
    "web_url": "http://nmcheck.gnome.org/check_network_status.txt",
    "web_url_secondary": "https://checkonline.home-assistant.io/online.txt",

I think you mentioned you updated to the latest alpha version a couple days ago, but if you could ask to “check for updates” again to make sure you’re on the latest, that latest version includes some fixes to the LED behavior.

(venv) neon@neon:~$ ping -c5
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=55 time=16.6 ms
64 bytes from icmp_seq=2 ttl=55 time=18.0 ms
64 bytes from icmp_seq=3 ttl=55 time=15.5 ms
64 bytes from icmp_seq=4 ttl=55 time=12.8 ms
64 bytes from icmp_seq=5 ttl=55 time=19.0 ms

— ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 12.832/16.398/19.014/2.149 ms

(venv) neon@neon:~$ ping -c3
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=116 time=19.0 ms
64 bytes from icmp_seq=2 ttl=116 time=13.4 ms
64 bytes from icmp_seq=3 ttl=116 time=13.7 ms

— ping statistics —
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 13.426/15.375/18.989/2.557 ms

(venv) neon@neon:/tmp$ wget http://nmcheck.gnome.org/check_network_status.txt
–2023-04-27 09:46:34-- http://nmcheck.gnome.org/check_network_status.txt
Resolving nmcheck.gnome.org (nmcheck.gnome.org)… 2a04:4e42:200::347, 2a04:4e42:400::347, 2a04:4e42:600::347, …
Connecting to nmcheck.gnome.org (nmcheck.gnome.org)|2a04:4e42:200::347|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 25 [text/plain]
Saving to: ‘check_network_status.txt’

check_network_status.txt 100%[=====================================================>] 25 --.-KB/s in 0s

2023-04-27 09:46:35 (935 KB/s) - ‘check_network_status.txt’ saved [25/25]

(venv) neon@neon:/tmp$ cat check_network_status.txt
NetworkManager is online

(venv) neon@neon:/tmp$ wget https://checkonline.home-assistant.io/online.txt
–2023-04-27 09:47:25-- https://checkonline.home-assistant.io/online.txt
Resolving checkonline.home-assistant.io (checkonline.home-assistant.io)… 2606:4700:20::681a:4ee, 2606:4700:20::ac43:445a, 2606:4700:20::681a:5ee, …
Connecting to checkonline.home-assistant.io (checkonline.home-assistant.io)|2606:4700:20::681a:4ee|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 25 [text/plain]
Saving to: ‘online.txt’

online.txt 100%[====================================>] 25 --.-KB/s in 0s

2023-04-27 09:47:26 (11.4 MB/s) - ‘online.txt’ saved [25/25]

(venv) neon@neon:/tmp$ cat online.txt
NetworkManager is online

My wife asked me this morning “what is your obsession with updating that THING every morning” :wink:

From neon-cli

run updates

I am already up to date with version 23 point 4 point 24 alpha 10. Would you like to update anyways?
Okay, let me know later if you want to update.

I have to mention that I am running pi-hole as local dns resolver and I re-route all dns requests *:53 to local pihole on my router.
$dig @ www.neon.ai
;; reply from unexpected source:, expected

Could that be an issue ?

Ah! that is a better command you gave me!

check for updates

Would you like to update from version 23 point 4 point 4 to 23 point 4 point 24 alpha 10?


Initiating update. This will take several minutes.

That is confusing, i thought I already was on 23.4.24A10

That is strange… If an update fails, it will roll back to an earlier version (and display “Update Failed” instead of “Update Success” on screen), but you had previously reported to be on a newer version, so I don’t see why you’d have an older version unless you explicitly downgraded…

Networking all seems to be in order, but since there’s a question now about the alpha version being installed can you check that pip show neon-phal-plugin-linear-led reports version 0.2.0 is installed? That version brought in some improvements to persistent LED animations.

I did not downgrade.
What is the command to find the current (running) version of the software ?
Either neon voice or CLI command ?

What version is installed

I am running version 23 point 4 point 24 alpha 10.

(venv) neon@neon:~$ pip show neon-phal-plugin-linear-led
Name: neon-phal-plugin-linear-led
Version: 0.2.0
Summary: Linear/Ring LED Interface
Home-page: GitHub - NeonGeckoCom/neon-phal-plugin-linear_led: PHAL Plugin for interacting with an LED Ring
Author: Neongecko
Author-email: developers@neon.ai
License: BSD-3
Location: /home/neon/venv/lib/python3.7/site-packages
Requires: mycroft-messagebus-client, ovos-plugin-manager, ovos-utils, sj201-interface

1 Like

I thought I would share my experience as well over the past few months.

a) I have tried change the wakeword to mycroft. because it keeps randomly replying to queries nobody has asked.
for some reasons no matter how quick I try to say wakeword it still understands “wake word” as two different words. So i just get “sorry I don’t understand” you might need to say this a different way.

b) I have asked it for update. It says it is going to but I see no change. Edit: rebooted the machine and now it seems to be doing something. the lights on the top were read previously but after I rebooted they were not on. So maybe something was going on.

1 Like

Thanks for the feedback @amunizp. I’ll do my best to help.

  1. What version are you running please?
    (You can ask Neon “What version is installed” in order to find out, or check in the swipe-down system menu.)

I ask because the older releases didn’t have the wakeword change available. The current release (v23.4.4) does, and the current beta release (v23.5.9a15, from yesterday) also does.

Telling Neon you want to run updates or tapping the alert should result in a verbal response such as “Would you like to update to version…?” . It won’t run actually perform a version update without a verbal confirmation “yes” from you, so if you’re not getting that prompt it’s not functioning as intended.

  1. Telling Neon to change your wakeword should result in a verbal response from Neon, something like “okay, I’ll start listening for ‘Hey Mycroft’ now”.

  2. What are you using for a boot drive? Did you end up getting yourself an SSD, or are still on a USB? I ask because we’ve seen a number of USB failures crop up. That’s always a good thing to check on first, since I hate to see folks burn up their time and patience on possible hardware errors.

First off I had a problem installing Neon. The instructions said that no other USB should be plugged in along with the Neon.ai OS. There was another USB but I thought that was a WIFI dongle and so did not remove it. That resulted in Neon OS not being installed. I then downloaded the image from the website onto another USB and still no luck. Then out of desperation, I removed the SAN disk…and, Hey Presto, Neon got installed. I suggest the instructions are clearer for us newbies…Remove any other USB or USB like drive which is plugged in before trying to install Neon.

Now, there are no instructions for what this SanDisk does. Do I plug it back in when Neon has loaded? Should I remove the Neon OS USB after Neon is loaded. HELP! Some more baby steps for us newbies please!

OK I think point 3 is the root of all my problems. It is a USB 2.0.

I have the original USB stick with the original Mycroft dinkum OS that came with the machine. I think this is what @Dunbrokin is refering to “SanDisk”.

Sadly I live in UK and it seems I cannot benefit from your offer of the free SSD?

Would overwritting the original USB that came with the machine be a good solution?

What would you say are good specs of an SSD that will give me a good lasting effect? Better yet, do you have a brand that would be useful?

I am not afraid to use a screwdriver, would a good solution be to put in an a neon loaded raspberry pi SD card directly?

@amunzip You can absolutely benefit from our free USB offer -

TL:DR - put in an order, it’ll cost you $12 shipping & whatever import taxes the UK requires & I’ll send you an SSD instead of a USB.

Here’s the link, & I’ve kept the coupon code mycroftneon active: Neon AI OS Bootable USB Drive for Mycroft Mark II (64GB) | Neon AI

Thanks for being an engaged community member!

We’ve decided that the performance upgrade to SSD, especially as we add additional languages and features, is large enough that we won’t be sending out anymore USBs except by special request. All the orders I get now are going to get an automatic upgrade to SSD, and we’ll be changing our Square listings soon.

I’ll list the replacement & shipping cost for customs, the HS tariff codes & exact package contents, and explicitly state that you haven’t paid for the product, which is the best I can do toward an accurate import tax fee on your side.

We’re still hoping to find a European partner to send these out on our behalf, any leads are welcome. :slight_smile:


Part 2 - @amunizp Sorry, just realized that was an incomplete reply. I’ve had far too much caffeinated tea this morning I think :laughing:

Yes, you can absolutely overwrite the original SanDisk brand USB that came with your device, and it will work fine.

You don’t need a particularly fancy SSD drive to see excellent performance. The Mark II really doesn’t place a high load on it. We haven’t gone with a particular brand, and the specs on the ones I have right now are USB 3.1 (which is the important part) and about 400MB/s read & 250MB/s write speed (based on my testing with CrystalDiskMark).

If you want to dive deep into the weeds, those are the top speeds for moderately sized, sequential pieces of data. The Mark II OS systems actually mostly use much smaller, randomly accessed pieces of data. Those performance numbers are always lower. I have a research question that I haven’t had time to address, which is whether any particular SSD or even USB is particularly well suited to this use. If anyone reading this knows or wants to find out and share more about that, I would be delighted - and if folks haven’t figured it out yet, we’re happy to express our appreciation for community contributions with SSD drives & for larger projects even Mark IIs. :slight_smile:

I’m not sure about your question about “would a good solution be to put in an a neon loaded raspberry pi SD card directly?” I think we’ve had some discussion on this topic, and that the consensus was it wouldn’t be better than the SSD, so not worth the effort of trying to fit it inside the Mark II. That’s an off-the-cuff answer though.

1 Like

OK recieved the SSD some weeks ago. Yep seems more solid than my 5 year old Kingston USB stick. I updated it to the latest version. After a reboot it works OK. With the lovely Forrest green background.

But after some time (only notice it after a day) I notice the time in white letters and the background is black. It does not reply to any commands and the mic is off and on button does not show anything.

Looking at documentation Neon OS on the Mark II - NeonAI® Documentation I am currently finding out if hardware or software issue. I rebooted and restarted with same result. I do not have another working OS so I need to check the SD on a computer.

Yep, check on your computer, and then re-imaging the drive is a possible solution. Here is the link to the page with the most recent image. Daniel is putting a fresh one up today. Neon AI OS for the Mark II | Neon AI