Unable to record or install new skills

So I decided to try mycroft out on my new raspberry 3 and have found a few things that don’t work.

When I try to record it says no file exists (something like that) and can’t record. It acts like it’s recording and stops when I tell it to, but telling it to play recording gets an error message, no file or something. I’m pretty sure I could make the file and it would work but it’s just something I was testing to see what this thing can do. .

I can’t add any of the new skills ( I haven’t tried them all but none work out of several) I tried “install daily meditation” cause it’s on the available skills list but mycroft says “I didn’t find any skill named daily meditation”
I tried quite a few more from the community list but none of them work so I gave up and came here.

I’m new to this, my version is whatever is in the raspberry link on the download page and I haven’t tried installing anything manually cause that kinda defeats the fun I expected to have.

Its an interesting project, I’ll try to get some stuff installed tomorrow even if I have to do it manually.

Thank you to everyone whos made it work, I could never do these things so thank you very much.

I read some of the other skills wont install threads, tried a reboot to see if anything would update, but no, I can’t get skills with voice, still havent tried manual install.

I set a timer by saying “set alarm for 5 minutes” and this thing absolutely freaked out. the bell instantly started ringing once set, mycroft kept trying to talk but cut itself off with the bell and it had all sorts of problems like lost connection with servers and just tons of stuff flying by on the screen. It basically went insane and I had to pull the plug.

It’s not what I expected to be honest. I know its a work in progress but not even being able to use this thing as a timer is depressing. I’m just being honest, please don’t take this as an attack.

Hi @beardo, sorry to hear your first experience with Mycroft has been disappointing. Can I check a few details with you?

  • Are you using an RPi 3 or RPi 3B+?
  • Are you comfortable SSH’ing into the RPi? If so there’s a few things we can try to help.

RPI 3 and I’ve used ssh a few times to root phones and upgrades some routers, so yes it’s something I can work with.

I fired it up this morning and tried the timer again and it worked fine, but skill installs kept giving the not found error.

I’ll also be trying to change the sound output to bluetooth so I’ve not given up yet. I would be more than happy and most appreciative to try anything to get this to work. Eventually I’d like to do some home automation.

I just took a few minutes to try to connect with putty. I am certain I changed the PW and it is not mycroft. I changed the PW again used passwd pi. I do have the right password but putty is saying access denied.

I really have no idea whats going on. I said yes to the fingerprint popup thing, I definitely have the right password and putty does try to connect in so much as it asks for the password.

OK I figured it out. The instructions at https://mycroft.ai/documentation/picroft/#connecting-to-picroft-via-ssh say to * Open up your favorite terminal program, like PuTTy on Windows, or a new terminal on Linux

  • ssh pi@IPADDRESS
    but if you put the ssh in front it tries to login to the name ssh pi, so it’s right for linux but wrong for putty it seems. It’s kinda confusing and really should have the putty login differentiate from the linux login for dummies like me.

Anyway, I’m in with putty and ready to try anything. I’ll be copy/pasting the bluetooth instruction in thru putty, hopefully I don’t screw it up.

Fire away with whatever to get the installs working, I’ll do my best.

1 Like

This may be too much for me. I tried using mycroft-msm with source /opt/venvs/mycroft-core/bin/activate at the command line like it says at https://mycroft.ai/documentation/msm/ but I get a no dir or file found error.

I guess its already running though as msm list does give me the list. These instructions are confusing to me, but I’m not too bright so… I do exactly what it says and the response is not what it says.

I tried installing with msm install “daily meditation” but its the same exact error as with voice, not found and closest match is game-zork by forslund.

I am trying but this is way to hard and things just are not working. It’s killing the cool factor I expected from this device

OK so I looked at the msm list output and saw cocktails was not installed. I installed it. It seems the only skills I can install are those listed by list. I’m guessing I’m not connecting to a repo? I’m stumped.

So now I’m trying to setup BT. I’ve follwed the instructions at https://mycroft.ai/documentation/picroft/picroft-audio/#how-to-output-audio-through-bluetooth

I’ve done scan, pair and trust all good but when I go to connect it says failed to connect. I scan again and its still there, try to pair again, it says its already paired, trust again, all good, go to connect and it fails.

I just dont get this. I am following the instructions word for word and it just does not work.

I got it. It needed pulseaudio-bluettoth-module installed.

But now that its connected there is no sound. It’s just one problem after another. It’s incredibly frustrating.

And now another problem. I try to reboot to get sound and it says JSONDecoderError… bunch of stuff and I can no longer boot after installing pulseaudio.

So so frustrating. I can’t fix whatever this crazy error is. To reburn or go over to alexa… I wish this project were more active. The idea is great but nothing works!

The documentation is not so good for this project, please take that as fair and useful criticism. I’m retired and have hours to waste. For some average working joe this would be far to much trouble.

Yeah Alexa was the way to go. Easy install and everything just works. It’s unfortunate that no one here knows why adding skills to mycroft would be a problem. Its super easy with alexa and the forums are active and helpful. This place is just too quiet and/or unwelcoming to noobs.

Good luck with your project, maybe in a few years you’ll have something functional.

Well, thanks for giving us a go, and sorry to hear you encountered some difficulties.

Good luck with Alexa!

Hi Kathy,

It seems I experienced the same issue I reported here : Picroft errors : time & Skills