[Solved]Picroft errors : time & Skills


After a reboot I didn’t find the directory /opt/venvs I worked with earlyer on Picroft. I guess that I put my fingers in some wrong place.

I flashed a SD card and initialized this new one but I got the same result, no /opt/venvs.

Despite the pairing, it’s this issue with the time which is not localized :

where are you
'>> My settings tell me I’m at Quimper Brittany France
what time is it
'>> 3:43:11 pm EDT, Tuesday, September 25, 2018
what time is it in Quimper
'>> 9:44:22 pm CEST, Tuesday, September 25, 2018

Looking at the log, there are errors with Skills settings :

21:44:26.232 - SKILLS - DEBUG - {“type”: “enclosure.eyes.blink”, “data”: {“side”: “b”}, “context”: null}
21:44:26.242 - SKILLS - DEBUG - {“type”: “recognizer_loop:audio_output_start”, “data”: {}, “context”: null}
21:44:32.950 - SKILLS - DEBUG - {“type”: “recognizer_loop:audio_output_end”, “data”: {}, “context”: null}
21:44:32.963 - SKILLS - DEBUG - {“type”: “enclosure.eyes.blink”, “data”: {“side”: “b”}, “context”: null}
~~~~7.891 - mycroft.skills.settings:_request_other_settings:452 - INFO - syncing settings with other devices from server for SarcasmSkill
21:44:47.895 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai

21:44:57.140 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
~~~~es.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/f8742220-068d-4cd8-97b9-7804421ad83d HTTP/1.1" 200 443
21:44:57.676 - mycroft.skills.settings:initialize_remote_settings:121 - INFO - settingsmeta.json exist for NewsSkill
21:44:57.679 - mycroft.skills.settings:_request_other_settings:452 - INFO - syncing settings with other devices from server for NewsSkill
21:44:57.683 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
~~~~1/device/f8742220-068d-4cd8-97b9-7804421ad83d/userSkill?identifier=skill-npr-news-a77dceb31e51813df3ba930c20419abb HTTP/1.1" 200 1646
21:44:58.321 - mycroft.skills.settings:_poll_skill_settings:385 - ERROR - 'value'
21:44:58.323 - mycroft.skills.settings:_poll_skill_settings:386 - ERROR -
Traceback (most recent call last):
File "/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.14-py2.7.egg/mycroft/skills/settings.py", line 379, in _poll_skill_settings
~~~~/local/lib/python2.7/site-packages/mycroft_core-0.9.14-py2.7.egg/mycroft/skills/settings.py", line 142, in initialize_remote_settings
File "/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.14-py2.7.egg/mycroft/skills/settings.py", line 211, in save_skill_settings
self[field['name']] = field['value']
KeyError: 'value'

Thank you for helping.
1 Like

@henridbr - thank you for reaching out to us!

I will ping @KathyReid so she can get her expertise on this issue but for now I’m going to dig in and see if I can’t pinpoint the issue. Either, I or her will respond back ASAP with some help!


Thanks Daren,

This is my log : mycroft-skills.log

I saved this log 2 days ago : mycroft-skills.log before


OK so a few things jump out immediately @henridbr.

  • The Picroft software version being run here is very old - over 12 months old, and …
  • This means that it’s trying to use Python 2.7 instead of Python 3.4, which in turn means that a lot of the Skills won’t work properly.

So, what we need to do here is get mycroft-core up to date.

There’s a couple of ways to get on to a new software version. Firstly, you could burn a new Picroft image.

Alternatively, if you do
sudo apt-get update && apt-get upgrade
that should kick off an update :slight_smile:

Thanks Kathy,

I agree but if you look at the log I saved 2 days ago, Python version used was 3.4.

It’s a fresh install of the same image and nothing was changed on my side.

What I get with my attempt to upgrade :

pi@picroft:/ $ sudo apt-get update && apt-get upgrade
Get:1 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Ign http://apt.mopidy.com jessie InRelease
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://apt.mopidy.com jessie Release.gpg
Hit http://apt.mopidy.com jessie Release
Get:2 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,537 kB]
Hit http://apt.mopidy.com jessie/main Sources
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://apt.mopidy.com jessie/contrib Sources
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://apt.mopidy.com jessie/non-free Sources
Hit http://apt.mopidy.com jessie/main armhf Packages
Hit http://apt.mopidy.com jessie/contrib armhf Packages
Hit http://apt.mopidy.com jessie/non-free armhf Packages
Hit http://repo.mycroft.ai debian InRelease
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Hit http://repo.mycroft.ai debian/main armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Get:3 http://repo.mycroft.ai debian/main Translation-en_GB [339 B]
Get:4 http://repo.mycroft.ai debian/main Translation-en [336 B]
Get:5 http://repo.mycroft.ai debian/main Translation-en_GB [339 B]
Get:6 http://repo.mycroft.ai debian/main Translation-en [336 B]
Get:7 http://repo.mycroft.ai debian/main Translation-en_GB [339 B]
Get:8 http://repo.mycroft.ai debian/main Translation-en [336 B]
Get:9 http://repo.mycroft.ai debian/main Translation-en_GB [339 B]
Get:10 http://repo.mycroft.ai debian/main Translation-en [336 B]
Get:11 http://repo.mycroft.ai debian/main Translation-en_GB [339 B]
Ign http://repo.mycroft.ai debian/main Translation-en_GB
Get:12 http://repo.mycroft.ai debian/main Translation-en [336 B]
Ign http://repo.mycroft.ai debian/main Translation-en
Get:13 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3 kB]
Get:14 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [84.2 kB]
Ign http://apt.mopidy.com jessie/contrib Translation-en_GB
Get:15 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
Ign http://apt.mopidy.com jessie/contrib Translation-en
Ign http://apt.mopidy.com jessie/main Translation-en_GB
Ign http://apt.mopidy.com jessie/main Translation-en
Ign http://apt.mopidy.com jessie/non-free Translation-en_GB
Ign http://apt.mopidy.com jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,680 kB in 20s (467 kB/s)
Reading package lists… Done
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Hi Kathy,

I halted and powered off the Raspberry.
When powered on, Picroft reboot 3 times and upgrade seamless from 0.9.14 to 18.8.1 :grinning:

It’s ok right now, don’t ask me why !
The other guy who was so frustrated might encounter the same issue.
I think that what I did solve the problem because at that time something had occurred elsewhere.


Great! Thanks for letting us know @henridbr!

In other words, what I did was a hard reboot !