Setting up SSH access Mycroft Mark II

Please forgive the rookie question, what is the username for the CLI for mycroft mark2?

I’ve input my ssh pubkey (RSA) on the site, and typically I would use a command like -


but uh, what is that username? It’s not root, it’s not mycroft. It’s not in the documentation. Please help.

Think i might have answered my own question. I didn’t search the documentation, I scanned the sidebar with my eyes and didn’t see the page. After searching I found this:

Which appears to be what I needed. I’ll give this a try. I’ll reply back when I’m all logged in for search engine’s sake for the next person.

Yup, I’m in now.

The username was mycroft all along but the default port is 8222 and I didn’t know that earlier.


I got my Mark 2 yesterday. Your findings helped a lot! But they aren’t enough for me to have success yet.
I can’t log in via SSH because it requires an SSH key to be added to it.
The instructions say I need to use the website to submit my private key, but I can’t find a place to do that. Any tips?

Go to Account and click on edit on the device you registered. Under advanced settings there is a box where you need to paste the public key, Note this is the PUBLIC key, the private key stays on your own PC.

I don’t see a place for that there. See the screenshot:

1 Like

Not sure what causes that - I see this for my Mark II with the dinkum software it came with but I the same hardware with the OVOS software that I registered as a separate device looks like your screenshot.

1 Like

I have this same screen, there’s no option to add my public key

Is there any known resolution ?

Have you tried different browsers?


Firefox 107.0.1 Linux and Chromium Version 108.0.5359.71 (Official Build) Arch Linux (64-bit).
I just tried Chrome on my Google Pixel 6 too.

Same screen. I’m completely missing the Advanced Settings option


I had t o switch to the beta image to get the advanced tab to show up. If this is a requirement it is not documented in the Mark II documentation in any way I saw.

Hey there, it shouldn’t be required to switch to the Beta release.

My assumption is that the initial pairing with our Pantacor update servers failed. Without this information we assume that the device is not a retail Mark II, and is more likely a Sandbox or other image that don’t use this public key field.

Any reboot it should re-attempt the connection with the update servers, so when you switched to Beta that would also have triggered a new attempt.

So you can switch back to Stable if you want and that will retain the public SSH key field.

I had to flash the beta image to the USB key though, the option to switch releases was not available until I reflashed.
Indeed I had a funny behavior the first time I paired the Mark II but then subsequently removed and repaired it. I didn’t see the option for advanced/ssh/software release until I reflashed the image.

Anyway flashing the beta image unblocked me.

I am running the stock version of Dinkum that ships with the Mark II, and at some point in the last couple of months, I was able to add in a public key, and I can successfully ssh into my unit. However, when I go to Devices in, the ability to add in an ssh key is no longer available. I also noticed that the “Hardware Version” in Device settings is showing as “None”. I tried un-pairing and re-pairing the device, but this hasn’t made a difference.

Should I be re-flashing it with Dinkum beta? Is there a way to update it manually?

I have the same problem. There is no field for my ssh key in the device settings.
I aslo tried with the beta version, no change. Is there any way I can put my ssh onto the usb stick directly?
All help is appreciated.

I am encountering a similar problem, where neither the hardware version nor the Advanced Settings are displayed. My device, which arrived with the pre-installed stock Dinkum software, is also affected. Despite attempting to reflash the USB stick using the stable version of the Dinkum software, the issue persists.

Should I try to flash the Beta version?

I just woke up, so I’m in drive-by mode. Sorry about that. Here’s a FAQ.

Users are strongly encouraged to switch from Dinkum to NeonOS.