Picroft install - "Locale not supported" error when starting mycroft-cli-client

I just flashed a new image of picroft (raspbian_Picroft_2018-01-19_v0.9.1.zip) on a new SD card that I use on a rapsberry pi 3.

It didn’t seem to be listening “out of the box” so I first used say_to_microft “hey microft pair device”.
I got an error about mycroft.conf not found so I copied the content of this page in a ~/.mycroft/mycroft.conf I just created and the command worked fine since microft told me the pairing code that I added on my home page.

I used the test_microphone command to check that my mic is working properly and I got a nice and clean playback.

Since the voice recognition it was still not working, I started mycroft_cli_client manually after SSHing my raspberry and I got the following error:

pi@picroft:~ $ mycroft-cli-client
15:11:27.216 - root - INFO - Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
15:11:27.353 - root - INFO - Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt
Locale not supported, please try starting the command and setting LANG="en_US.UTF-8"

        Example: LANG="en_US.UTF-8" ./start-mycroft.sh cli

I checked and my locales were all en_GB.UTF-8 so I used raspbi-config to generate and set up the system locales to en_US.UTF-8.

What can I do to solve my problem?

I think there is still an error in the latest picroft build.

OK, this sounds like a bug we’ve been tracking for a while where it seems the microphone doesn’t respond. Some of the information we have indicates this may not be a microphone problem but a problem with the mycroft-skills service.

Can you please try

sudo service mycroft-skills stop && sudo service mycroft-skills start
at the pi@xxx terminal and let us know how you go?

Kind regards,

Thanks for your answer Kathy.

Restarting the mycroft-skills service doesn’t seem to fix things. I think I will wait for a new image to be released and test that later.

OK, thanks for letting us know