Small problem with PiCroft

Hi guys, i have small problem with my PiCroft. I create image on sd card, plug mic usb (playstation eye) + jack (speakers) + hdmi. PiCroft is paired with (registered). And now PiCroft is not respond. What can i do?

I have the same problem at the moment… It seems to affect a lot of people on picroft. Might be something wrong with the 18.02 update

I would probably wait a couple of days and keep trying to update…
Sure it will be patched.

kind regards

Hey there @Hydro_HD, thanks for reporting this, we have several reports of this on Picroft on 18.02. Are you able to confirm for me:

  • Picroft on RPi3
  • Version 18.02
  • Microphone: PS Eye 3
  • Boots OK
  • Pairs OK
  • Listens to Wake Word
  • Does not respond to commands

Also happening on raspberry with the Google AIY hardware Kathy.

I noticed that in the speechlog the connection with the gives never completes when talking, and gives error 429.
Which is - too many requests. Could be a missing useragent, or perhaps the device is actually spamming, but I doubt that. A missing user agent could also explain why I am not getting the raspberry pi image in Home now sees both my devices as two Mark 1’s

Not sure where that code is being run from though.

12:12:45.951 - requests.packages.urllib3.connectionpool - DEBUG - “POST /v1/stt?lang=en-US&limit=1 HTTP/1.1” 429 62

I tried looking for the changes, but I could not figure out what it could be,
That explains getting no utterances back anyway.

Also cli client still works, so it has to be the api-request failing.


1 Like

Great debugging @tjoen, I’ll flag this internally

This evening my picroft began exhibiting the same behaviour.
It was working on 18.02 for several days right up till this evening.
Was there a work around for this?
I can confirm
Picroft on RPi3
Version 18.02
Microphone: USB Mic
Boots OK
Pairs OK
Listens to Wake Word
STT and Utterance are accurate
Does not respond to commands

Thanks for the great work you and your team are doing.
And a happy International Womens Day to you.

We have only a possible workaround.
Can you try running
msm update
on the command line (not in the client) and see if this makes a difference?

Kind regards,

I attempted msm update with no success, I received several errors on the lock file for each skill. I next attempted sudo msm update then performed a reboot and still have no response from my commands. For the record I also performed apt get update followed by apt get dist-upgrade. My picroft remains unresponsive. Let me know if there is anything else I can do to test/support this effort.
Thanks for the assistance.

OK, the only other thing I can thin of here is to stop and start the mycroft-skill service:

sudo service mycroft-skills stop
sudo service mycroft-skills start

Do we know if this is an issue affecting all picroft 18.02 or just some instances? Would re-creating the SD card solve the problem or is it inherit in the image?
Also can msm be used to uninstall skills? My thought is to rollback some of the skills I have been playing with and see if my situation improves.
Lastly if I stop the Mycroft-skills service and not re-start it should Mycroft continue to respond to the wake word and only respond “I don’t know how to do that”? This way I could possibly begin to isolate the issue to a particular skill.