MyCroft Not Responding to Wake Word

Hi All! As the title says, my MyCroft install isn’t responding to the wake word. It was working, and then my microphone stopped responding. I rebooted, and my microphone works again, but the wake word doesn’t get a response. The MyCroft install is working, though, because in CLI mode I can type a question and get an audible response back. My mic is working in other applications as wel, and it displays on the levels in the CLI.

I am running Linux Mint 18 with a Playstation Eye camera as my microphone.

Thanks in Advance!

Hi khantroll, that’s an interesting one.

Does the microphone work for other purposes? Eg if you type in:
“Set a timer”
You should be prompted for how long a timer you want. If you then speak the response, is that heard and transcribed by Mycroft?

Given the mic levels are displaying in the CLI, I’m wondering if it’s the mic not being heard, or something wrong with the wake word spotting.

It seems to be a problem with wake word spotting, because when I did the set a timer test, it detected my answer. I tried immediately afterword to call the wakeword, and it is still not responding to it

Another odd thing: according to the CLI, it picked up my wakeword at some point this morning (I’ve only said it more then a dozen times) but it never dinged to let me know so I didn’t give it a command.

I am experiencing the same behavior on my Picroft. It started yesterday after it had been working properly. I have rebooted numerous times and even powered down and back up.

This was in the log:

~~~~or_update on picroft-google-aiy-voicekit: SkillModified(Uncommitted changes:

The SkillModified(Uncommitted changes: is generally because you have made edits to that skills and hence it will no longer automatically update the Skill to avoid overwriting your changes.

Can (either or both of) you send us some logs to have a look at what might be happening?
The easiest method is to tell Mycroft to “Create a support ticket” and it will then upload these to a free service and email you a link. If you’re not keen on posting that publicly here, then send it to either me or support at mycroft . ai

Email sent with log files.

The error message was not appearing today, but Mycroft is still not responding to the wake word.

1 Like

After the system upgrade last night, Mycroft is responding to the wake word for my Picroft again!

1 Like

I told it to create a support ticket, but I never received an email. Is there another way to send in the relevant information?

The logs are located at /var/log/mycroft/*.log

You can upload individual files to termbin by running:
cat /some/file.log | nc 9999

So to get links for all five logs you can do something like:
for log in /var/log/mycroft/*.log; do echo "====$log====" | cat - $log | nc 9999; done

There was a glitch in the special release we generate for the backend upgrade which broke Precise. We corrected it about 12 hours ago (see release 19.2.9 at, so hopefully you are back in business!

Sadly, my wakeword is still not functioning. I’ve uploaded the logs to termbin though.


I’d very much like the link to the logs on termbin if possible.

Also as Steve said check that you’re not still on v19.2.8 using the bad precise code.

Even i am facing the same problem. Did you find the solution for it?

I also have same problem with wake word i have tried with set timer only for this it response properly