MSK Not Working

I am using the MSK tool directly on my Picroft but when I am entering all my details, it stops and this line shows up.

pi@picroft:~ $ msk create
Enter a short unique skill name (ie. “siren alarm” or “pizza orderer”): test

Class name: TestSkill
Repo name: test-skill

Looks good? (Y/n) y
Enter what your skill should say to respond:

  • help me I am trapped

Enter some example phrases to trigger your skill:

  • where are you

Enter a one line description for your skill (ie. Orders fresh pizzas from the store): just a simple skill
Enter a long description:

this is a long discription of the skill

Enter author: steven
Traceback (most recent call last):
File “/opt/venvs/mycroft-core/bin/msk”, line 11, in
load_entry_point(‘msk==0.3.10’, ‘console_scripts’, ‘msk’)()
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/msk/”, line 64, in main
return console_actionsargs.action.perform()
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/msk/actions/”, line 278, in perform
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/msk/actions/”, line 258, in commit_changes
self.git.commit(message=‘Initial commit’)
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/git/”, line 548, in
return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/git/”, line 1014, in _call_process
return self.execute(call, **exec_kwargs)
File “/opt/venvs/mycroft-core/lib/python3.4/site-packages/git/”, line 825, in execute
raise GitCommandError(command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd(‘git’) failed due to: exit code(128)
cmdline: git commit --message=Initial commit
stderr: ’
*** Please tell me who you are.


git config --global “
git config --global “Your Name”

to set your account’s default identity.
Omit --global to set the identity only in this repository.

fatal: empty ident name (for <mycroft@picroft.(none)>) not allowed’

is there something I am missing?

1 Like

Did you run the git commands?

1 Like

I have the same problem and i did run the git commands and double checked. Everything else is working.

Hi there @Kopsi - are you able to post the error messages you’re receiving?

Best, Kathy

So after an afternoon and evening of uninstalling with pip, reinstalling via git, removing git version again, because it broke my mycroft core somehow (that was propably my fault) i removed everything mycroft related from my pc and set it up again from the beginning. Mycroft core, then mycroft skills, then mycroft skill maker (via pip). Now it works. I don’t really know what the issue was, but it’s mostly fixed now. The only thing not working is creating a git repo, since my credentials don’t get accepted.
But for now I’m content with having it work locally.
Regards, Kopsi


Thanks so much for confirming for us, @kopsi.
I think you might need a personal access token for command line access:

Hi @KathyReid, @Kopsi

Yesterday, I experimented the same issue when trying to install msk on Picroft 18.8.4.
I lost my permissions to use msm and got errors from Github.
Using sudo, msm looked working but I didn’t know if there was other defaults.

I looked at your idea of the personal access token.
It seemed I had to do this for each mycroft skill, so I gave up.
And I did not understand why I have to do that.

I can’t investigate more because I am working on skills.
I choose to flash a sd card with the image I saved and restart a new device.

Not sure to try msk before this issue is officially marked as solved.

That’s part of the problem - I don’t know what the specific issue is, to try and replicate and diagnose it.

Are there error messages, or terminal output, that you can show me?

Hi @KathyReid

I am sorry. I forgot that the doc is written for Linux installation and had a blank when reading that “msk is already installed in Picroft”. Yes I read it and I tried to install msk on Picroft.
I apologize for my mistake and cover my head with ashes :confounded:

Not at all! I’m sorry I wasn’t clearer.

i have the exact same issue.