Mimic 3 TTS Models Failing to Load with INVALID_PROTOBUF Error

I am encountering an issue with Mimic3 TTS models failing to load with the error “INVALID_PROTOBUF”. Despite following the installation steps and ensuring the correct setup, the models are not loading correctly and the error persists.

Steps to reproduce the behavior:

  1. Download and install the Mimic3 TTS models using the provided commands.
  2. Attempt to use the Mimic3 TTS models with the following command:Preformatted text
mimic3 --voice en_US/ljspeech_low "This is a test of the ljspeech voice model." > test_output_ljspeech.wav
Observe the error message: "Load model from /home/user/.local/share/mycroft/mimic3/voices/en_US/ljspeech_low/generator.onnx failed: Protobuf parsing failed."

The expected behavior is for the TTS model to load successfully and generate the audio output without errors.

Here are the relevant log files and error messages:

[ONNXRuntimeError] : 7 : INVALID_PROTOBUF : Load model from /home/user/.local/share/mycroft/mimic3/voices/en_US/ljspeech_low/generator.onnx failed: Protobuf parsing failed.

Environment:

  • Device type: Desktop
  • OS: Ubuntu 20.04
  • Mycroft-core version: N/A (using Mimic3 standalone)
  • Other versions: Mimic3 TTS version 0.2.5, Python 3.10

Additional context:

I have tried downloading and using multiple voice models (en_US/ljspeech_low, en_US/cmu-arctic_low, en_US/vctk_low) and encountered the same error with each. I followed the installation and usage instructions carefully but have not been able to resolve the issue. Any guidance or suggestions to resolve this problem would be greatly appreciated.

Thank you for your assistance.

I also have this same error. If I find the solution I will post it.

1 Like