Mark II stopped booting - fans at max

Shutting down the Mark II seems to result in the fans staying on at max power until power is disconnected. Or at least for almost an hour after shut down and I needed to actually sleep.
On trying the mycroft-core image, on a different USB, it would not boot, though the fans were still functioning at full blast. But now the Dinkum USB doesn’t boot either.

1 Like

Hi there,

I’ve split this out to a new thread as it sounds like a unique issue.

First about the fan - this will operate at 100% speed anytime the device is powered and the software hasn’t told it to do otherwise. We knew that this happened on shutdown however the Mark II is really intended to be left on, so changing this didn’t make it to the priority list.

It sounds like you wanted to shut down the Mark II as it prevented you from sleeping, but left the power plugged in. If that’s right, it seems like have two issues to solve:

  1. Providing a night time mode that completely blacks out the device and either stops the fan altogether or puts it on a very low setting.
  2. Making it clear when the device can be unplugged after shutdown.

Would you agree with those two points, or are there other reasons I’m not catching?

In terms of the device not booting, it would be good to get some more detail on what happens when you plug in the Dinkum USB that came with the Mark II?

You can see what an expected boot process looks like here:

It would be good to know where it starts to differ when you plug the device in?

Can I also confirm that you are turning the power off and on between boots of the Mark II? Eg:

  1. Shutdown
  2. Remove power plug
  3. Remove USB
  4. Insert new USB
  5. Insert power plug
  6. Mark II starts to boot

With the mycroft-core image that didn’t work, can you post the filename and SHA256 hash of the file you used to flash that USB?

1 Like

Yes, good idea, and brainstorming a bit … I found an app for my cell phone that does exactly one task - it shows the current time and you can choose muted colors. So I put it on the charger and when I wake up early, I can see the current time. So a good option would be to to have the Mark II go black, but another would be to just show the time and be quiet until the wakeup alarm goes off… Just a thought …

As for the fan, I vote for “stops it altogether” - I don’t believe the Pi will overheat at night.

-Mike Mac

Sorry for the late reply. Been busy.

So that isn’t what happens when I try to boot up. The fan just goes on and nothing else. I don’t think it’s an issue with the screen, since the mycroft doesn’t show up as connected to the internet on the router. I haven’t fully take it apart but from what I can tell, there aren’t any loose connections to the screen. I don’t know how to get the SHA256 hash, but the file for the image I used is named MarkII_arm-rpi64_Prod_013-stable_2021-12-13.img

The problem is that even the Dinkem USB doesn’t boot either.

Hey @wingzeroalchemist,

I’m waiting to get some back from a couple of other customers, but I believe that something in that old Dev Kit stable image is causing an issue on the Raspberry Pi’s shipped with the new production Mark II’s. At least from customer assisted debugging the Raspberry Pi seems to be effectively bricked.

I’ve removed the download link for that image and added a big warning to our docs not to use it until we can determine exactly what’s happening. I’d recommend deleting the image file just to make sure you don’t accidentally load it onto a future device. All the new Mark II software works on the Dev Kits, but the Dev Kit images will not work on the new hardware - and in this case may actually harm it.

If you want to confirm that yours is the same you can remove the Pi, plug it into a normal Raspberry Pi USB type C power adapter and try to boot any normal RPi image eg Raspbian. Nothing would happen.

Of course there was no way for you to know that and the image filename includes “Mark II” “stable” “prod” so any logical person would assume it would work. We’ll definitely replace any Mark II’s that have gotten into this state, so please reach out to and point out this message. They’ll then kick off a return and replacement process to get you a new Mark II.

1 Like

my Mark II just stopped booting.
Just black screen and full fan speed.
I’ll read through this thread, wanted to panic first.

Mine was running fine about 2 days ago. I looked at it later in the day, and the screen was black. Thought I had hit a power cord or something, but nope. Fan at max speed, black screen, and logging into MyMycroft, it’s showing as not connected.

Pulling the power cord, waiting 1 min, replug and nothing.
Did the same, moved USB drive over, nothing.

“He’s Dead Jim” being said by Bones McCoy comes to mind. And way out of this? Got it delivered in the December mailing, if that makes a difference.

1 Like

This has happened to me, too. I haven’t spent much time trying to debug yet.

yup this is what happened with mine

Hey there,

Unfortunately we’ve seen a few instances now where the USB drive has failed after a short period of usage.

To confirm if this is the case for your Mark II, take the USB out of your Mark II and plug it into a computer. It likely won’t be mountable ie you won’t see it show up like a normal USB storage device. However it should show up on your usb bus (run lsusb on a linux system)

Another way to verify this is to burn the Mycroft software onto a different USB drive (preferably 16GB or larger), plug that into the Mark II and power it up. This should boot as normal.

We’re still investigating why these are failing - whether it’s a manufacturing fault on the USB drives themselves or if the OS is somehow causing them to fail.

If your Mark II ends up in this state, please try the above then contact us via to get a free replacement. In your email please include your order number and the steps you’ve taken to confirm this as this will make it much quicker for us to process. If you don’t explicitly say what you’ve tried, my first email response will be asking if you’ve done the above…

I might have some ideas about what could be going on. Posted this over at the Neon OS Matrix channels but will do it here as well for your information.

Journald by default is configured to automatically write either to memory or disk. This is done by the “Storage=auto” setting within journald.conf

There are a few options. Volatile, Persistent and Auto.

  • volatile means writing to /run/log/journal which is mounted as tmpfs into memory
  • persistant means writing to /var/log/journal which most of the time is just a folder on disk.
  • auto means writing to /run however as soon as systemd has all things mounted and /var becomes available switch over to that location.

I believe Dinkum is running quite some systemd services that are all configured to output to journald. As mycroft is rather verbal on logging, especially when running the default DEBUG log setting, that are enormous writes to disk. If it then also writes to EXt4 with journalling it even has a write multiplication of 4x - 6x.

Writing all these log lines continuously to disk if not configured correctly is killing embedded storage devices. There are more of these disk killers out there, like for instance fake-hwclock. This writes the time every few seconds to a file such that when the rpi reboots and as it doesn’t have a real time clock, it can grab the time from that file preventing it to be thrown back into 1900.

Combining this with a USB disk that has a long time bug of completely shutting down when to much bad blocks are detected.

This could be the cause of these devices just going black after a period of time.

Anyhow, perhaps you should just leave a Mark2 running on your desk and run IO tools in a shell to see how active the disk IO is. Especially the writing to disk.

1 Like

yup I see this, USB is not even detected on PC.

As a reminder, anyone who is having problems with their Mark II, please email for support. I’m doing my best to resolve issues and issue RMAs when necessary.

Note: I was having a somewhat similar issue. @gez-mycroft issued a new USB to me and that resolved it. So think about the possibility that it could be an issue with your boot media or the files on the boot media.

I might be experiencing a similar problem today. I powered the MyCroft II unit off without any issue. I performed the needed task (organizing my home/office desk).

When I tried to power the unit back on, I started hearing the infamous fan issue. I am not sure it was at any max, but it was audible (for me that is loud enough). Luckily I have a backup image of the MyCroft after I had it initially configured.

The MyCroft II was able to boot off the backup usb without any issue and the fans did not seem to loud.

When I put the original SanDisk USB back into the unit, the same issue happen again: The fans were pretty loud and the unit never completed its boot.

Given what I experienced, I am thinking this could be an issue with the USB. @michael-mycroft or @gez-mycroft, should I log this as a support ticket? This is the MyCroft batch that was shipped late last year.

Look forward to the feedback

Gez has departed. We are given to understand that, if you’re looking to talk to MycroftAI, you’ll get a faster response by email, which I thought was, but Michael suggests above that would also do the trick.

thank you @ChanceNCounter

1 Like