MkII Dinkum Radio Skill: Logging Issue Causing(?) Audio Quit After 1.5 Hours

TLDR: probable major clue discovered re: audio quiting on Dinkum Radio Skill after 1.5 hours of play – it seems to be related to verbose Dinkum logging combined with the lack of space available on the boot device (in this case the Sandisk 16GB loaded with Dinkum USB that came from with the Mark II).

NOTE: This may be related to Radio skill audio drops out

Since our family got our Mark II (running Dinkum) in November, of the very limited set of skills that come with Dinkum, the skill we have gotten the most out of is the Dinkum Radio Skill.* This was especially fun from December 25th on when we used “play Christmas radio” (see also a non-exhaustive list of channels I made to fill all twelve days of Christmas with Christmas cheer.

Or we would have if on day 9 of Christmas we hadn’t had an situation with the Mark II / Dinkum that stopped us dead in our tracks and it took us several weeks of sorting it out with the help of the community and Mycroft, to narrow it down to a Dinkum/USB failure (much better than the alternative – a Mark II hardware failure. But that story is told elsewhere. Anyway, we love the Dinkum Radio Skill, but there was a consistent audio stoppage after about 1.5 hours where the only remedy we found was a system reboot (actually I have reason to believe we had found the “audio reboot” choice on menu that probably would have worked too, but we didn’t see that until just recently).

Now our family believes we have discovered a major clue. When we got a brand new Dinkum USB from (thank you @gez-mycroft!) , everything worked again (yeah!), but we also had this same problem where the radio cut audio off after about 1.5 hours. It just so happened that I got an (Samsung T7) SSD and (using the recommended Balena Etcher software) I flashed the image of Dkinkum onto it. So booting off of the SSD, problem goes away and we’ve been able to enjoy the Dinkum Radio Skill running non-stop for hours on end with no interruptions of the audio function.

Therefore I believe this problem may be related to some of the problems reported by others here in the forum (such as Excessive Dinkum journal logging, combined with small USB boot drive may be causing issues.) where Dinkum is writing log files or in some other way using disk space and may run into size limits which cause the audio stream to fail (and possibly cause the drive to fail partly or completely such as Mycroft AI Sandisk USB drives with Dinkum failing). The USB drives is shipping with the Mark II are 16GB, whereas the SSD I’m now using is 1TB. I noticed that the complimentary NeonOS USB is 64GB.

This prompts me to speculate that perhaps Neon picked up on an issue with Mycroft (probably both Dinkum and Classic) that it does a lot (maybe more than is advisable for a device which is supposed to be “consumer ready,”) of logging / journaling and somewhat side-steps the issue by simply providing a larger USB boot drive.

*(for now on I am making it clear whether skills are the Classic version or the Dinkum version, because obviously they are not the same).

Also see: