What is the trick on RasPi?

Hi folks,
I got mycroft nicely running on my notebook (thanks to people in this forum) also with my own hotword and recognizer. I decided to get it running also in Raspberry Pi, but not with “ready to use” images, but I took version directly from git. To set up everything took some time, but it pretends to run. What does it mean? In the log is everything ok, typed input works, tts works, the audio bar is moving, audiotest was ok, but hotword is never recognized. I switched already from my own into default - to be sure - but still the same. Since I have it running on the notebook I am already nicely convinced that the setup is the same and ok. So what is the trick?

Are you using a viable model for your wake word this time?

I’ve seen Precise fail to download particularly on RPi’s, so would be worth checking if that has loaded correctly in ~/.mycroft/precise

With the official images, this is pre-loaded.

Dear baconar, I would like to point to the part where I am writing “I switched already from my own into default - to be sure - but still the same.” So THIS TIME I am aware of problems with different version and despite the fact that my model is and ALWAYS WAS ok, for the testing I am using default setup.

yes, 182MB was loaded. And I thing if there was a problem I would see something in voice.log. But there I see just: mycroft.client.speech.mic:listen:553 | Waiting for wake word…

Before of course:
mycroft.client.speech.hotword_factory:load_module:312 | Loading “hey mycroft” wake word via precise
plus messages about the model update …

I also tried precise-engine from ~/.mycroft/precise on /tmp/test.wav created via audiotest and result are as expected. 2 said hotwords are nicely visible.