Web Terminal & Web CLI client

How to install Web Terminal

Install Web Terminal with mycroft-msm install https://github.com/andlo/web-terminal-skill.git

This should install and start a Web CLI client wich can be accesed at http://device:8080
where device is the hostname of your mycroft device.

Yo can start at terminal by saying “hey mycroft - run web terminal”. Then there will be a full shell running wich you can access from a browser on http://:8080 where is the hostname of your mycroft device.

On settings on home.mycroft.ai you can change ports and set if CLI and/or Terminal should auto start or not.

To stop the Web Terminal say “Hey Mycroft - Exit Web Terminal” and to stop the Web CLI Client say “Hey Mycroft - Exit CLI client”

Web Terminal does not connects to any serviceses

How to test Web Terminal

  • Configure the Skill Settings in home.mycroft.ai
  • Speak `“hey mycroft - run web terminal”
  • Mycroft should `start a webterminal

I know it installs and run on picroft, but dont know other platforms.
Autostart settings and port settings on home.mycroft.ai should work, but test is always good.

If SkillManager is stopped or restarted both Web Terminal and Web CLI client should continue running, and can be stoed after skills are loaded again as teh skill stores the pids in the settings.json file.

Where feedback on Web Terminal should be directed a

Feedback on the this Skill through [Issues on GitHub] (https://github.com/andlo/web-terminal-skill/issues), via [Mycroft Chat] (https://chat.mycroft.ai) or reply on this post.


Got this skill running on my Picroft (with Google-AIY-Kit), but had to sudo apt-get install libwebsockets-dev manually before mycroft-msm install ... worked. Great work - makes my life easier, as I can work now on Mycroft with my iPad while sitting on the couch…

Tried to install on a Mark-I as well but failed while building libwebsockets (resp. dependency libuv )

1 Like

Great. Ill look into that as soon as posible. Think it Just need to ad depencies in manifest file.

Strange, as in the manifest.yml the libwebsockets-dev is included. So why it wassnt installed at your Picroft I cant fugure out…

    apt-get: cmake g++ pkg-config git vim-common libwebsockets-dev libjson-c-dev libssl-dev
    dnf: make g++ pkg-config git vim-common libwebsockets-devel json-c-devel openssl-devel```

Hey, @andlo useful tool. I seemed to work fine an a Linux Based VM I had running on Virtual Box, but after installing and running it on a Picroft I’m unable to connect via the browser. Browser reports unable to connect at server:8022 despite Microft consol reporting it’s running and how to connect?!

I installed the plugin on an Unbuntu Docker instance and run into the same issue above.