Wake word will not work

I’ve tried everything and Mycroft WILL NOT respond to “Hey Mycroft” at all.

Its a laptop running Kubuntu 20.xx

It easily responds to comments from even farther away when I type 'set a timer". I’ve even purposely mumbled and it still got it right. It just wont respond to any wake word I’ve tried.

Precise and pocketsphinx both do nothing even when I put my mouth directly up to the mic and yell the wake word.

I need help!!!

Have you tried the other options (Jarvis, Christopher, Ezra) - in Manage Device Defaults?

You might want to tune the
“sensitivity = 0.6” (precise-specific) [between 0 an 1] or
"treshold = 1e-30 (pocketsphinx-specific)

like here

Ok, I will try this. I am running mycroft as a snap and there are two identical mycroft config files in different spots. Which one is the right one?

Also, yes, I’ve tried other wake words, to no avail.

Sounds like your mic isn’t the device it’s listening on. Check the audio troubleshooting guide and see if that’s it?

mycroft will read the config files from each location, for personal instances, use ~/.mycroft/mycroft.conf, for system wide stuff you can use /etc/mycroft/mycroft.conf

Adjusted the settings in mycroft.conf file. It did nothing

I have no ~/.mycroft/mycroft.conf or /etc/mycroft/mycroft.conf folders or even directories…

sorry for the withdrawn posts. I have no idea how to work this forum all it ever says is “429 Too Many Requests”

Audio Troubleshooting

1 Like

Mycroft can hear me perfectly fine but the wake word will not work

If it’s hearing you, then it’s hearing the wake word, unless you’ve made some changes.

It hears me when i type “set a timer” and that initiates the listening for me to say, for example, “5 minutes”. Saying “Hey Mycroft” (or any other wake word) doesn’t work at all.

This is a completely default install of Mycroft AI. I’ve also tried completely reinstalling it.

I would continue to tinker with sensitivity, threshold or other settings like shown here

If you want to dig deep it should be beneficial (it sounds like you have a somewhat unique speech pattern) to create a custom wake word. But that process is intense.

Out of curiosity: What wake word listener is in use?

Ok. Thanks for the advice. By the way I have a normal US speech pattern with no lisp or any other impediment. It just baffles me that it won’t work.

I have tried both pocket Sphinx and Precise.

I tried installing the non snap version just to see, and it won’t even start listening. It shows the mic level that jumps up and down accordingly to my voice but it won’t even start listening.


There’s a script called mycroft-mic-test under /mycroft-core/bin which you might want to use to hear what mycroft is hearing.

1 Like

I have seen strangeness with the wakeword similar to this. I can easily trigger the wake word, so can my daughter, but my wife cannot trigger it no matter what she tries. My understanding is this is due to the training data that was used to train the model. You may have success training your own wake word using one of the skills found on the forum.

And in this case opting in to the open data set would’t be beneficial (to those who have the problem) because mycroft is hearing everything but the wakeword (or what it identifies as such) - or do i get something wrong there?

It would be beneficial. If it’s hearing that many false positives, when tagging starts back up again they will get classified as such and used to improve the models.

Does this apply to false negatives (which would be the case here)? i actually don’t know if they could track/classify that

Yes. Watch the developer sync calls, there’s mention of the classifications for tagging (wake word/not/close-to-wakeword) in the last two.