Wake word is not activated by female voice

I’m new user of the Mycroft. I installed Picroft one week ago.
I found problem with wake up word and my wife. I’m able to activate Mycroft by wake up word with 99% success.

But Mycroft does not react to wake up word from my wife. She can try different pronunciation, different tones. She tried everything, but she is not able to wake up Mycroft.

I have exactly the same problem as is described here in topic “Wake Word not recognized when spoken by a female”

I have Picroft with default setting of the Mycroft.

I understand that way for me is use custom wake up word. (I want to stay with Precise mode).

I started with Source install:

  1. git clone GitHub - MycroftAI/mycroft-precise: A lightweight, simple-to-use, RNN wake word listener
  2. cd mycroft-precise
  3. ./setup.sh

Points 1 & 2 are successfully done.
But in point 3 I got these error:

(.venv) pi@picroft:~/mycroft-precise $ ./setup.sh
Reading package lists… Done
Building dependency tree
Reading state information… Done
curl is already the newest version (7.64.0-4+deb10u1).
cython is already the newest version (0.29.2-2).
libhdf5-dev is already the newest version (1.10.4+repack-10).
libopenblas-dev is already the newest version (0.3.5+ds-3+rpi1).
portaudio19-dev is already the newest version (19.6.0-1).
python3-h5py is already the newest version (2.8.0-3).
swig is already the newest version (3.0.12-2).
python3-pip is already the newest version (18.1-5+rpt1).
The following package was automatically installed and is no longer required:
Use ‘sudo apt autoremove’ to remove it.
Suggested packages:
libatlas-doc liblapack-doc liblcms2-utils python-pil-doc python3-pil-dbg python-scipy-doc
The following NEW packages will be installed:
libatlas-base-dev libatlas3-base libimagequant0 liblcms2-2 libpulse-dev libpulse-mainloop-glib0 libwebpdemux2 python3-decorator python3-olefile python3-pil python3-scipy
0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 451 kB/15.1 MB of archives.
After this operation, 72.6 MB of additional disk space will be used.
Err:1 http//raspbian.raspberrypi.org/raspbian buster/main armhf libwebpdemux2 armhf 0.6.1-2
404 Not Found [IP: 80]
Err:2 http//raspbian.raspberrypi.org/raspbian buster/main armhf python3-pil armhf 5.4.1-2+deb10u2
404 Not Found [IP: 80]
E: Failed to fetch http//raspbian.raspberrypi.org/raspbian/pool/main/libw/libwebp/libwebpdemux2_0.6.1-2_armhf.deb 404 Not Found [IP: 80]
E: Failed to fetch http//raspbian.raspberrypi.org/raspbian/pool/main/p/pillow/python3-pil_5.4.1-2+deb10u2_armhf.deb 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

As I understand the problem is with python3-scipy - this addon is not possible to install. I tried install it separately but I got the error above.

Can somebody please help how to solve it? I want to share Mycroft experience with my wife :smile:

I followed these articles:

I had the same issue and it’s disappointing that it’s still present at release.

@sparkyvision linked to a guide on recording your own wake word in this thread:

Update: Sorry, posted before I read your second post. I haven’t tried to train my own wake word yet but I’ll come back if I figure it out.