Unsatisfying Audio-troubles

Hi there,
i’ve had a lot of different setups for Raspberry PI, BananaPI, Genuine Linux Mint distributions and there is NO setup, that works properly concerning the audio.

When using Netbook with internal microphone and speakers, recording works fine, but replay sounds like Mickey Mouse on speed. The bits seem not to match from record to playback.

Using Raspberry is worse, because audiotest works fine with me, making some noise is correctly replayed, but when starting Mycroft CLI, there is no audio recording / recognition, even the level meter shows nothing. Putting in commands by keyboard, Mycroft will work and tells me the wheather or plays the news.

On BananaPi no audio works, doesn’t matter, if it’s pulseaudio or alsa.

There’s a lot of trouble setting alsa or pulseaudio to new defaults. Sometimes Raspberry requires sudo, but when installing new defaults as sudo, these defaults won’t be recognized, when starting Mycroft CLI the normal way.
Starting Mycroft als sudo, lots of text is produced on the screen, at least it isn’t working.

All this stuff makes me sad, because i hoped to get an independant voice assistant, but seems to me, that i don’t have any luck with this.

My proposal is, to put more efforts in reliable audio support, adjustable audio setting in the CLI and very important an easy way to adapt to other languages. All trials to put a German version on my raspberry ended in a bunch of chaos.

Please please please do me the favor and put some work on these problems. The Forum tells lots of stuff to similar problems with audio, working not properly.

It could be a great milestone to get more users by having easier setups with less problems.

Thank you.

HI @caruso
Yes audio is frustrating and sometimes requere big effort to get working. The different combination of hardware and software is challenging.
That said, the picroft image do work as long as one is using the hardware that the setup is made for. But if one has other hardware the “fun” begins.

I dont expect mycroft (the company) can have support and settings for to many different hardware. But the hardware in the Mark I and II one can expect will work out of the box. But other hardware support has to be community driven. And for that the community needs people like you having hardware that dosnt work out of the box with mycroft.core. And then when you or someone else figure out how to get it working, and which settings are requered then add info in the docs and if on raspberrypi enhance the setup script for picroft. Dooing PR’s to the respective repos so it can be included into the releases for others to enjoy.

editing mycroft configs can be done by mycroft-confir edit (user|system) which seems to me a easy way to edit the configs. The docs has some documentation on audio and audiotroubleshooting.


And then if this isnt enough ask in forum and chat to get more help.

this hardware is repported working with picroft and if yu get some other hardware to work it would be great that that is added to the list.

You can add to the docks by making a PR to the docs repo or open an isssue or tell @gez-mycroft in the chat or a post here on forum.

An easier way to change language is a good idea. I were thinking of making a skill that change the nessesary settings so shifting between languages could be done by voice. I hassnt yet come further thn thinking of such a skill.

I really hope you figure out how to get audio working with your hardware as having a independant voice assistant that is open and hackable in any way one could think of is really fun.

I also had audio problems especially with an USB soundcard. At least I solved the problems by deactivating all hardware resp. drivers which are unused. Have a look at this theme:


Hi there,
i’ve found a useful offer for a seeed-2mic-array at ebay’s, so i purchsed it. With installing Mycroft / picroft, stopping the setup-wizard and following the short installation guide on GitHub it works perfectly without further configuration.

Only problem is, that some skills won’t work, so the date-time-skill is installed, but when trying to ask for time oder date, mycroft tells me, that “he didn’t understand, but is learning new things every day…”

Uninstall and reinstall the skill had no effect, but that’s another topic.

Cheers Caruso

I’m curious, do you know what an intent is? There is so much confusion floating around in this thread i have to ask. The assessment “Some skills won’t work” then becomes “It doesn’t understand the sequence of words” shortly. (without the audio setup being involved whatsoever)

I get it, mycroft has a steap learning curve, especially if you step outside the realm of “officially supported”. And the most things i’ve read here are outside that realm (devices, Linux distributions, language, etc.) which require you to do a deep dive into the mechanics of mycroft.

A look into the vocab is always beneficial:

(das |) (Uhrzeit | Uhr) ((rechts |) jetzt |) (bitte |)
Hast du die (aktuelle|) Uhrzeit
aktuelle Zeit

This is what you have to ask. There is another way by combining Query.voc and Time.voc. The upper one showing the state of german translation (of this skill) - lengendary translation i have to add. Reminds me of “Ich möchte diesen Teppich nicht kaufen”. Yet there are many ways to contribute

Hi SGee,

yes, i browsed through all of these folders, contained in the skills and i also found the de-de-Files with the correct activation words for the skill. The problem is obviously not the word itselt, but the activation of the skill itselt.
I checked the logs and found a lot of strange errors concerning the date-time.
A few minutes ago i updated the “requests”, the pip and VLC, now the error is gone and time/date works with the same words used before.

So there was no problem in using the vocab.
Thanks anyway.

then it would be beneficial to take those strange errors seriously and give feedback about those, so that these errors can be narrowed down by the staff.

…unfortunately i cleared the logs to gather only the current messages, so older errors are no longer available.

If it occurs again, i will do so.

Thank you.