Unpaired mycroft and can't pair again

Hi, I unpaired mycroft on the website, and would like to pair it again.

The identity folder is clear apart from pycache.

When I launch the core again, mycroft does not ask to be paired, but instead just wouldn’t connect to any server. What am I doing wrong?

[UPDATE] I even downloaded and set up a fresh mycroft core. Still the problem persists. The internet connection is fine.

[UPDATE2] I completely reset my virtualbox (lol) and now it works. But then my final question is: How do I successfully ‘unpair’ Mycroft. Say I want to develop some stuff, then unpair it and send the entire core to somebody else so they can pair and test it out? Seems like my simple unpairing on Mycroft-AI website didn’t do it properly.


1 Like

i had the same problem - but it stopped when i reinstalled mycroft :sunglasses:

Have a look at the picroft recipe;

At the end, they reset everything before releasing the image. I believe you are after the same.

Hey there,

Can I confirm your ~/.mycroft/identity directory for the user running Mycroft was empty?

Based on your description, it sounds like when you restarted Mycroft it attempted to pair but couldn’t connect to the server is that right?

Do you have the logs from it? Was it the Mycroft servers it couldn’t connect to or the local messagebus?

Hi, thanks for your reply.

Couldn’t connect to servers. /identity folder was empty.

Essentially I unpaired Mycroft from the web interface, then tried to pair it again. Message bus worked fine. Anyways, it sorted after re-installing fully. Unfortunately don’t have the logs but I remember on the bus it was “error connecting to servers” and Mycroft would reply “I’m having difficulty communicating with the server”.

Could it have been a locality issue? I think I was signed up as China but our network traffic goes through HK.