Unable to install new skills

Hello, I’m able to request some basic information from Mycroft AI, but I’m having issues adding skills with the following being generated in the CLI. Can someone please suggest what is going wrong?

08:52:04.161 - main:handle_utterance:62 - INFO - Utterance: [u’install new skill’]
08:52:04.263 - mycroft.skills.core:wrapper:607 - ERROR - An error occurred while processing a request in Skill Installer Skill
Traceback (most recent call last):
File “/home/shaun/mycroft-core/mycroft/skills/core.py”, line 598, in wrapper
File “/opt/mycroft/skills/skill-installer/init.py”, line 174, in install
skills = self.search_for_skill(search, self.get_skill_list())
File “/opt/mycroft/skills/skill-installer/init.py”, line 96, in get_skill_list
self.ansi_escape.sub(’’, check_output([BIN, ‘list’])).split(’\n’)
File “/usr/bin/anaconda/lib/python2.7/subprocess.py”, line 573, in check_output
raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command ‘[’/home/shaun/mycroft-core/msm/msm’, ‘list’]’ returned non-zero exit status 111

I think this might be one for @forslund or @Mn0491

Hi, seems like the skill has problems getting the skill list. (Return status 111)

If this is the case the problem can be either your internet connection or that github has rate limited the request (happens at times). If it’s a rate limiting thing you might have to wait a couple of hours before it starts working again.

I’ll add a note to catch the error and report back useful info if this occurs.


Thanks guys,

I’ve since tried again and am still getting connection errors (can’t access mycroft.ai). It’s strange though, because I’m able to access github and mycroft.ai via a browser/pinging/traceroute.

If there’s an update to catch the error, do I simple pull the repo again to receive this update?



Hey @shaunmbg are you able to paste the errors here sowe can take a closer look?

Below is a log containing a few attempts to install skills which all fail, and a weather query which succeeds. Please advise if there are any tests I can execute or logs I can provide which would help with any diagnoses


Can you try running curl -s "https://raw.githubusercontent.com/MycroftAI/mycroft-skills/master/.gitmodules" in a terminal and see if that results in an error message?

Thanks @shaunmbg that debugging information was super helpful.

There are two issues that I can see here;

  • The Utterance you’re speaking is Install new skill. There is no Skill called ‘New Skill’ - have you tried this by saying the name of a Skill like Install number generator or Install skill the cows? Ah, I can see you try this later on in the log :slight_smile:

  • The second issue I see here is that msm is exiting with error code 111. That means that the Device cannot see the mycroft-skills GitHub repo and look through the .gitmodules to find a Skill that matches your Utterance.

Is your Internet connection OK?

Thanks guys, this has pinpointed the issue.

Using curl as requested doesn’t generate any errors, but if I remove the slient / -s flag, the following is reported:

curl "https://raw.githubusercontent.com/MycroftAI/mycroft-skills/master/.gitmodules"
curl: (77) error setting certificate verify locations:
CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none

This indicates that the certificate reference fix that @KathyReid helped me with previously hadn’t persisted correctly (to be honest, I didn’t realise it was required beyond the initial installation anyway). By initiating a bash session and ensuring the CURL_CA_BUNDLE flag was set correctly, I’m now able to install skills!

Thanks again for your help.


Great troubleshooting @shaunmbg - and thanks for writing up the solution!