Trouble connecting Mark 1 to Wifi

HI this is a long belated cry for help. I have tried a WIFI dongle and trying to set it up the way your suppose to i cant use the dongle because I cant install necessary drivers and the start page is taking to long to load can some one help me.

BTW!!! i am using a year old Mycroft mark 1 unit that I connected to the internet via ethernet but his placement was horrid.

Mark-I Wifi-setup use internal Wifi and it will not recognize the dongle during setup-phase. Regarding the drivers consider that Mark-I is still on Debian-Jessie, drivers for Stretch and Buster will probably not work.

but thankyou for explaning the dongole issue

Hi there, I’ve bumped this to a new thread as it seems to be its own issue.

It sounds like you can successfully connect to the MYCROFT network, but is not loading properly when you are connected is that right?

How far away is the device you are using to connect to the MYCROFT wifi hotspot?

If you have an ethernet connection available and are comfortable ssh’ing into your device, you could set the Wifi credentials manually in your wpa_supplicant.conf. Let me know if you need instructions for that.

I have a monitor hooked up to Mycroft so i don’t need to use ssh and yes if there is a faster way of connecting him to the internet please give it to me

yes i would like the instructions

okay whilst I was trying and weighting for your instructions i looked for a way to edit the conf and i found it, Editing the wpa_supplicant.conf([note not using Ethernet cable]) but when i did it i am getting
[ Error writing /ect/wpa_supplicant.conf: no such file or directory ]
(note looks mine looks like )
GNU nano 2.2.6__________________________________________________________________________________modified

(not like)

now i am looking at a reddit post from 2 years ago ( that says i am looking for a completely different directory.


  1. dose my wpa_supplicant-conf not exist in my Mycroft mark 1 unit
  2. is the reddit post right because i was looking at picroft stuff
  3. did i type it wrowng


1 Like

ok so I did type something wrong and now I do have a connection to WIFI. I am a little put off because he said he said he could not launch or find something i am going to check the WIFI again but he is still not working. is there any thing else than the WIFI conf i need to change

btw i curently am in the client and it is saying
l~~~~ycroftAI/precise-data/raw/dist/armv71/latest (caused by newconnectionerror (’ <urllib3.conection.verifiedHTIPSconection object at 0x6c1d590>: failed to establish a new connection: [errno -2] name or service not known’))")))

its ETC not ECT

I WAS NOT GOING TO ANSWER BECAUSE CAPSLOCK IS ANNOYING, PLEASE DONT USE IT AND BE A GOOD NETIZEN. Typing in all caps is Internet code for shouting, and it is rude.

Okay sorry man I just wanted to enficise some thing

Hey, glad you worked it out!

Is that working now with the path corrected from ect to etc?

Yes but aparantly he says there is still more I also posted the error message I got. Is it possible to connect mycroft to 5 ghz WiFi.

Raspberry Pi3 based Mycroft-devices (e.g. Mark-I or Picroft) do not support 5GHz Wifi by default, because Pi3 does not have a 5GHz capable Wifi-chip onboard. You may try a USB-Wifi-Dongle with 5GHz chipset…

1 Like

On the Raspberry Pi 3B+ and Raspberry Pi 4B, you will also need to set the country code, so that the 5GHz networking can choose the correct frequency bands. You can do this using the raspi-config application: select the ‘Localisation Options’ menu, then ‘Change Wi-Fi Country’. Alternatively, you can edit the wpa_supplicant.conf file and add the following. (Note: you need to replace ‘GB’ with the 2 letter ISO code of your country. See Wikipedia for a list of 2 letter ISO 3166-1 country codes.)

1 Like

so I found a mistake when i was looking back on the .conf. and i fixed it and i have a new error message
l~~~~ycroftAI/percise-data/raw/diat/armu71/latest (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0x6bd644f0>: Falied to establish a new connection: [Errno-2] Name of sevice not known’))")))

so what diose this error message mean and how do I fix it

I miss gez

btw i am using an actual mark 1 not piecroft

just restarted mycroft and he says that he can not set up his net work

Hey, on the surface it looks like a DNS failure. Can you post the config you are using, with your password replaced of course :slight_smile:

Please format this as code by using three backticks (usually to the left of the 1 key) like so:

your configuration

or is it still:

    ssid="fort knox"
    psk="secret password"

Actually just noticed that has mismatched parantheses, so make sure its network={

Can you verify if the device is connecting to the router either from the DHCP registrations on your router, or run ifconfig on the device.

What sort of authentication are you using on your network?
Do you have a hidden SSID? If so try adding scan_ssid=1 to the network