Trouble adding Pandora

Noob to Picroft, but have used Raspberry Pis for years. I cannot seem to get any of the music services to work. First I tried adding Pandora and it errored out stating I need Piano bar. So I attempted to install pianobar using command line syntax… sudo apt-get install pianobar
But that errored out with two 404 errors, stating this:

I assume I just need to add a repository… if so… can some one please add the correct syntax here? Thanks

Picroft is very, very out of date. You’d have to update the OS to the latest release to get the package from apt, which introduces some other issues. I did this last year for two Picrofts and it was a whole ordeal.

From a supportability perspective, you’re better off standing up an OVOS headless instance using the Raspian image, but be aware the Pandora skill you’re looking at isn’t supported by the OVOS Common Play (OCP) they’re using. There’s an MVP Pandora skill available that I’m planning to update some time likely this weekend: GitHub - JarbasSkills/skill-pandora

1 Like

Thanks - Pandora was just the first app I tried. I’m really just trying to get ANY music service working so I can ditch my Al**a. Is there any other service that may work more easily?

OVOS and Neon have a number of OCP skills that work currently: GitHub - OpenVoiceOS/awesome-ocp-skills: Media skills for OCP, music, movies, radio, audiobooks and more!

I’m also in the code review process of a Plex skill that is working well for my library at home so far: GitHub - d-mcknight/skill-plex: Plex Media Skill (updated code is currently in the PR)

Spotify is also in the works but not quite done yet. :slightly_smiling_face:


As I understand it, both Pandora and Spotify retracted their open voice APIs.

-Mike Mac

Interesting, I hadn’t heard about Pandora! Do you have a link handy about the API restrictions? There are a number of open source projects available to hit Pandora’s APIs already - is it a restriction on using a single key/account for multiple users, or a restriction on using a voice frontend altogether?

So just to clarify - I am 3 days into building my PiCroft - so things are still really new to me. I cannot seem to get it working. Here is what I did - what did I miss?

  1. ran command line mycoft-msm install GitHub - JarbasSkills/skill-radio-browser
  2. the installation seemed to go well, but at the bottom of the process it showed a couple errors…
  3. Then I spoke this command: “Hey Mycroft, play heavy metal radio”
  4. Picroft responded “Give me a moment to check for that. It sounds like you are trying to listen to some music, but you have not setup any music skills. Please go to to install a new skill.”

Am I doing something wrong? Thanks

the skill you tried to install builds on the OCP framework for ovos-core, while you can install it + the framework in picroft, you should instead use a OVOS or Neon image

picroft is abandonware, years without updates

mycroft-core itself is no longer maintained, ovos-core is the community maintained replacement

1 Like

Aha! Thats what I was sensing, but no one was coming right out and saying it! Thank you. I presume OVOS or Neon are similar, privacy based voice assistants?

OVOS was started by community members when mycroft focused on the mark2 and stopped reviewing PRs, at first we focused on companion software but eventually needed to become a full fork

with the recent mycroft’s demise that means that a drop in fully compatible replacement with years of extra development was available, made by long term community members involved in the original code base since it’s early days

you can see a timeline of events here