SSH failure on Windows and Linux

I’m getting a Permission denied (public key). on Linux and a Connection timed out on Windows.

I can ping the unit which is connected on hard wire to my local network.

This is the first connection, there has never been an SSH to this Mark 2 dev unit yet.

Help much appreciated :slight_smile:

@phildhall, maybe sshd is listening on port 8181, not the standard 22?

See: What is port 8181 for?!

-Mike Mac

K - tried that, same issue. Was working on 8222 as per instructions, definitely not on 22.

From the -v it looked like the 8222 was getting to the mycroft, but not finding the public key. So my current thought is that it’s not been delivered.

$ ssh -v -p 8222 mycroft@$IPADDYHERE

debug1: Reading configuration data /etc/ssh/ssh_config

But I’ve got a keyboard and monitor to hand so will try and get into the CLI directly when I get back to keyboard later.

Sigh - so wanting to crack on, but time and tide and all that :slight_smile:


This seems to have solved itself, in as much as I can now get into the .venv might have been a back end issue, unknown.