[SOLVED] Problems Changing Mycroft Password

When I try to change my password on the (main) Mycroft website, it simply does not work…

All I get is an error which says:
Password must have between 4 and 36 characters and contain at least one letter and number.

But here’s the thing - the password I want to use meets these requirements, and I was able to use a password of the same strength with my Mycroft Forum account!

Here’s the password I was going to use (obviously I will use something different now), and all of the passwords I have tried have been of a similar standard:

Any help would be appreciated, because the temporary password I am using now is strong-ish - but nowhere near as strong as I would normally use…

Thanks @gregory.opera for reporting this.

Just so I can replicate and hopefully resolve for you, can you please confirm which domain you were logging in to?

  • mycroft.ai (ie for WooCommerce)
  • home.mycroft.ai (for configuring your Mycroft Devices)

If it was home.mycroft.ai, can you confirm whether you where using email / password to log in, or a social account?

Many thanks,

The site I am having issues with is home.mycroft.ai (for configuring your devices)… I registered using an e-mail address (i.e. not a social account) and I am using a strong-ish temporary password, but I can not change it to something stronger, such as:

Thanks so much for confirming @gregory.opera, I’ll liaise with my colleagues and get it investigated for you :thumbsup:

1 Like

My colleague @matheus-mycroft investigated this straight away. We think it’s due to a regex which has an error, we’re going to fix this in our next release, so it just be 1-2 weeks away :thumbsup:


I’ll try with such a strong password again in two weeks and let you know how I go…

1 Like

Hi @KathyReid,

This issue does not appear to have been fixed at the time of writing… Any updates?

@matheus-mycroft is this change going to be released soon?

1 Like

I just chatted with my colleague Matheus, this change is in development and has been tested. We want to bounce it off our CTO first, and we’re then hoping to push it to production during our next home.mycroft.ai release window this Tuesday 12th June.

Hi @gregory.opera I can confirm the password change has now been pushed to production. The only restriction on the password is that it has an 8-character minimum.

Can you check and let us know how you go?

1 Like

All fixed.

Thanks Kathy! :sunglasses:

1 Like

Awesomesauce, thanks for confirming @gregory.opera !