[SOLVED]Picroft cannot get Logitech C525 webcam microphone to work with mycroft

Hi dear mycroft community,
I am openHAB user that is trying to get mycroft assist with turning on lights and AC around the house :slight_smile:

Mycroft is running on RPI 3B+, he speaks, he is registered, but unfortunately he is deaf, as he cannot hear me through Logitech C525 webcam.
the webcam should be fine, I can capture images from it with fswebcam tool

I tried to follow documentation, but steps are not that clear what to do even though C525 is listed as supported, in the mycroft setup wizard I have to select 4) unsuported good luck

So I start with alsamixer, which when I select HD webcam C525 says this sound device does not have any playback controls

So then I try with pulseaudio - i have defined the webcam as default input device

pactl list sources short:
0 alsa_input.usb-046d_HD_Webcam_C525_698D2B20-00.analog-mono module-alsa-card.c s16le 1ch 48000Hz RUNNING
1 alsa_output.platform-soc_audio.analog-stereo.monitor module-alsa-card.c s16le 2ch 48000Hz IDLE

(.venv) pi@mycroft:~ $ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 71
Tile Size: 65496
User Name: pi
Host Name: mycroft
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.platform-soc_audio.analog-stereo
Default Source: alsa_input.usb-046d_HD_Webcam_C525_698D2B20-00.analog-mono
Cookie: 310c:b3ef

so he should be using the camera as input source right?
when trying arecord and they aplay the file, it is silent - and my speaker works if I test with another file. speaker is just analog device connected to 3.5 audio out of PI.
Also, mycroft test mic same result, no sound is recorded.

It might be that microphone is muted or similar…any help would be appreciated, what steps to take, what else to check…

this command should increase the volume by 5%, and it works, but I dont know what [off] means…

amixer -D default sset Capture 5%+
Simple mixer control ‘Capture’,0
Capabilities: cvolume cvolume-joined cswitch cswitch-joined
Capture channels: Mono
Limits: Capture 0 - 65536
Mono: Capture 55698 [85%] [off]


Heh, it was indeed muted
amixer sset Capture toggle
fixed it, and it works!

sorry to spam your forum for nothing, but hope it will help someone…
now, installing openhab skills, let the games begin :slight_smile:

1 Like

Hey, glad it’s working, and thanks for posting the solution too :smile:
It can definitely help others facing the same issue in the future.

Hope the weekend hacking was fun!