[SOLVED]Mycroft stuck spinny blue eyes after a long time without use

Hi there!

For various reasons, my Mycroft Mark I has been staying on the shelf, plugged off, for several months. Now I would like to wake it up and start using it again. I plugged it back, but the eyes didn’t light up. So I followed the doc and did several hard-reboot. Now, the eyes are stuck in spinny blue mode. I already performed several hard reboots (current one must be my third or fourth) but no luck.

When I press the button on the top, I can access the menu (ssh, test, reset…). I tried to reset as I have nothing I would miss, but as soon as I leave the menu, I am stuck again in spinny mode, and again after hard reboot. I am not even sure the reset happened.

I also plugged a screen with hdmi to try to see what was happening, but my screen doesn’t even recognize it has been plugged on a computer.

Any idea?

Hi there @Korydween,

Thanks for giving Mycroft another chance, and sorry to hear you’ve had a poor experience when it’s been plugged in.

This documentation explains the expected Mycroft Mark 1 boot sequence, and what the different colour eyes mean.

If you are not moving past the grey spinny eyes, this means that Mycroft is unable to upgrade packages or Skills (Yellow Eyes).

We have several workarounds available for this;

  • Are you comfortable using ssh - if so there are some commands I can show you to upgrade manually.
  • If you have a Torx-10 screwdriver with a long handle, I can also provide a link to a more recent Mark 1 image to burn to SD card

Regarding the HDMI, plug in the HDMI cable and then reboot Mark 1 - Mark 1 needs a reboot to show HDMI output.

Best, Kathy

Hi @KathyReid
Thanks for your answer.
I am comfortable with ssh and have the screwdriver. Maybe let’s start with ssh if I can connect, that might be easier :slight_smile:

EDIT: I tried to connect to mycroft from inside my network using its internal address (192.168.x.y) but I can’t connect to it. I can’t even ping it… not sure if it will allow me to ssh.


First, we need to enable SSH on the Mark 1 and connect using ssh. To find Mycroft’s IP address, you can say
Hey Mycroft, what's your IP address.

Once that is done, you will be connected as user mycroft to the Mark 1.

Run the following command to determine what version of mycroft-core you are running. If you are at version 0.8 or 0.9 it’s going to be harder to get to the current build, but not impossible.

pi@mark_1:~ $ sudo apt list | grep mycroft

WARNING: apt does not have a stable CLI interface yet. Use with caution in scripts.

mycroft-core/unknown,now 18.8.6 armhf [installed,automatic]
mycroft-mark-1/unknown,now 18.8.6 armhf [installed]
mycroft-picroft/unknown 18.8.6 armhf
mycroft-wifi-setup/unknown,now 0.2.5 armhf [installed,automatic]

The above is the latest stable build.

Next, run;

pi@mark_1:~ $ sudo apt-get update && sudo apt-get upgrade

You will note that the raspberry-pi-kernel will be held back, because the Mark 1 runs on Raspbian Jessie Lite, not the current Raspbian Stretch Lite.

This may take 10-15 minutes, and will download several packages.

Next, we reboot

pi@mark_1:~ $ sudo reboot now

Next, we see if Mark 1 boots correctly. Either way, ssh in and we can see what version it’s running.

You can also see if you’re on the latest version by speaking;

Hey Mycroft, what version are you running? and he will tell you if you are on an old version.

Please let me know how you go.

Thanks for the answer, and sorry for my late reply. I have been trying various things because Mycroft doesn’t answer to its name so I can’t ask for its IP. It doesn’t answer either when I press the button once as it used to.

Also, information that might be important: I am outside the US and I am plugging Mycroft through an EU-US adapter. I wonder if this could cause problems. It used to work quite well though :frowning:

I guess we will have to go through burning the SD card…

I actually found the doc online and managed to burn the new image on the SD card. Thanks for the help, mycroft is back online! It also feels really nice to see all what has been developped since last time I turned it on.

1 Like

Thanks so much for confirming that you’re back online OK, @Korydween :slight_smile: