[SOLVED] Mark1 not updating

I’m trying to update from 18.2.13 beta. It attempts to update using 18.8.8 but fails with the error below:

01:01:32.062 - VersionCheckerSkill - ERROR - Could not find latest version.
Traceback (most recent call last):
File "/opt/mycroft/skills/skill-version-checker/__init__.py", line 69, in check_version
AttributeError: 'VersionCheckerSkill' object has no attribute 'bus'
01:01:32.080 - mycroft.util:wait_while_speaking:300 - INFO - mycroft.utils.wait_while_speaking() is depreciated, use mycroft.audio.wait_while_speaking() instead.

The skill doesn’t report that it fails verbally, it just hangs. Have to open up the mycroft-cli-client to get this info.

Thanks for reporting this @scherererer.

I can’t be sure what is happening here without more logs, but there are a couple of lines of enquiry:

  • For some reason, the Skill does not have the bus object passed. This could be because it hasn’t started up properly
  • Or, on boot, Mark 1 has updated the Version Checker Skill, which is ahead of version 18.2.13

I have an idea to solve this for you - if you’re comfortable ssh'ing in to the Mark 1 device?

  1. ssh into the Mark 1 instructions
  2. type the command sudo apt-get update && sudo apt-get upgrade. This will force an update of Mark 1, bypassing the version-checker Skill. Then what I’m hoping is that the Version Checker Skill that is installed will work on 18.8.9 of mycroft-core.

Let me know how you go - we have some other options like doing a system wipe, but I don’t want to have to use that unless it’s a last resort.

Best, Kathy


That did the trick, thanks!

1 Like

Thanks so much for confirming that it worked!
Happy Mark 1-ing!

1 Like