[SOLVED] Location not updating from home.mycroft.ai


I’ve just installed Picroft 2018-3-14 on a Raspberry Pi 3. I cannot set the location, as such mycroft still thinks that it’s in Lawrence Kansas and as such the time it gives me is incorrect.

I have changed the location in home.mycroft.ai. When I click the “save” it appears to save however when I reload the page the location field is blank. I have also tried getting mycroft to “update config” to no avail.

I have rebooted a number of times.

Does anyone have any ideas on how to fix this?


Thanks for reporting this, @LucasAmos and sorry to hear you’re encountering this issue.

We have a couple different spots where ‘Location’ is stored - both at the ‘Account’ level and on a per-‘Device’ level as well. Are both your account and Device set to the right location?

Device settings are in home.mycroft.ai under Your Name -> Devices.

Hi @KathyReid, thanks for the reply.

I have changed the location in both the ‘profile’ and ‘device’ sections of home.mycroft.ai

However only the location on the ‘profile’ section appears to persist.


Thanks for confirming.

How comfortable are you on a command line, @LucasAmos? If possible I’d like to inspect your web_config_cache.json file to see what it holds;

Hi @KathyReid.

I’ve ssh’ed into the picroft and inspected the relevant folder, however the web_config_cache.json file does not seem to be present.


Thanks so much @LucasAmos

@forslund - could this be another API 304 not modified issue?

The web_config_cache has been moved to /var/tmp/mycroft_web_cache.json.

If it’s a 304 issue the location should come down as expected if mycroft is restarted. I know @matheus-mycroft has been working on some issues with the location service recently…

Ah thanks, that explains why after a fresh reboot TTS defaults back to Mimic instead of Google for a few first minutes on my RPi-ReSpeaker-Rasbian stretch project.

Because I have this in fstab;

tmpfs /var/log tmpfs defaults 0 0
tmpfs /tmp tmpfs defaults 0 0
tmpfs /var/tmp tmpfs defaults 0 0

@LucasAmos a fix related to the location bug was pushed to home.mycroft.ai, could you see if it solved your issue? Thanks

1 Like

Thanks @matheus-mycroft that has fixed the issue :slight_smile: