[SOLVED itself] Yellow eyes and no sound output on Mark I

Okay, so based on the mycroft-cli-client, my Mark I is operating correctly…except for output. It is listening - I can talk to it and see it hear me correctly. Skills function - I can see that in the history and the log output.

The display goes from grey eyes to yellow eyes when it boots and stops there, and only changes in response to the button. Using the button to try to reset doesn’t seem to do anything; all other button operations seem to work normally so far.

There is no sound output from interacting with Mycroft, from speaker-test, from aplay, or from mycroft-audio-test. Alsamixer shows the sound card “snd_rpi_proto” and the default, which is PulseAudio. aplay -l lists

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpiproto [snd_rpi_proto], device 0: WM8731 HiFi wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pactl list sinks short:
0 auto_null module-null-sink.c s16le 2ch 44100Hz SUSPENDED
pactl list sources short:
0 auto_null.monitor module-null-sink.c s16le 2ch 44100Hz SUSPENDED

I had not really tried doing much with the unit until Monday night, and at first he was stuck on 0.8.14, so I ended up updating manually, which had seemed to work fine. Then I messed around with different voices for a while, and the following day I came home and was getting erratic voice responses (I wish I’d taken better notes on how) and a misshapen mouth. I think it was after rebooting at that point that I stopped getting any sound output, but at that time the face was still behaving. Somewhere in the process of poking around after that I ran sudo apt update and sudo apt full-upgrade, and it was after that I began getting stuck on the yellow eyes. I had to leave off messing with it at that point and didn’t realize until I got back to it tonight that apparently it is listening and functioning, just not displaying anything or producing sound output. I haven’t been able to figure out whether the display and sound issues are related or to make any more progress. Any suggestions?

Hey there @bobfuscator, sorry to hear you’re having these issues.

Yellow Eyes is something we encounter now and then, and it’s usually related to the Device doing some form of update, so your thinking on this one is definitely on the right track. I wonder if the full update is what’s done it.

In the past I’ve had a couple of tricks to get rid of Yellow Eyes, but it really depends on the underlying cause.

  • I’d try a couple more updates - ie sudo apt-get update && sudo apt-get install and see if that pulls down anything that the full-upgrade didn’t
  • Mycroft devices try to update on reboot. Try a couple of reboots.
  • If that doesn’t work we can always try a full reset but that will remove any Device configurations, pairing and any installed Skills, so it’s an option of last resort.

We’ve also seen Yellow Eyes be triggered when Skills can’t load (for a variety of reasons), but your Skills are loading so I don’t want to send you down this path :wink:

Please do keep me looped in to how you go, and if the updates and reboots don’t do the trick let me know and we will dig a bit deeper :thumbsup:

Best, Kathy

I rebooted again this morning and now I’m back to blue eyes after boot, working display, and no sound output. However, I also set up key-based authentication for SSH and was brain-dead enough to switch ports while I was at it–instead of enabling a second port, making sure I could connect to both, and then disabling port 22–and now I can’t connect. So I’ve got to figure out what I did wrong there before I can go back to troubleshooting the sound. I’ll have to get back to it after work.

@bobfuscator happens to the best of us :wink: Oh the things I have done in the absence of glorious coffee!

On the sound side of things, I’d have a go at restarting both the voice and audio services like this:

pi@mark_1:~ $ sudo service mycroft-speech-client restart
pi@mark_1:~ $ sudo service mycroft-audio restart 

Please let me know how you go,

Best, Kathy

Well, in the process of trying to get an hdmi cable and keyboard connected so I could see if that let me log in and fix the ssh settings, I ended up bumping the button, and he chirped. Sound is working again.

Now I just have to figure out how to get logged back in…or if I’m going to have to try to do a reset…

1 Like