[SOLVED] How to setup your location correctly on Home.mycroft.ai

Hello guys. Over the last couple of weeks, I have been part of the team doing support on email and other places. This is one of our FAQ that I wanted to post here to hopefully give people answers quickly and accurately.

Please note that this was posted on 12/5/2018, and we do have future plans to streamline this a little

Challenge: How do I set the location to be my location on Mycroft devices.

Answer Although the steps are simple to do, it is confusing the actual steps to take to fully get this switched over from default. The problem can have multiple reasons, but the main one is the configuration of home.mycroft.ai, and regardless the following should solve the issue.

  1. Log into your home.mycroft.ai account.

  2. Look up at the top right under your name.

  3. Click on Profile and find the location field. Input your location in either name of your city or zip code. Make sure you hit save at the top.

  4. What you have just done at this point is to set the default location for any NEW devices. But this will not help any current devices you have. This section is meant for you to use as a global default.

  5. Next, we need to go to your device settings for any device you have already set up. In that same drop down shown in step #2, you will see another section that says Devices. Click that and you should get a screen with your devices listed.

  6. Click on the device you are working with. On that next screen, you will see a location box as well. Change this to the location you want to use with this device.

  7. Make sure you hit save. At this point, your device should be getting the new configurations from the home.mycroft.ai. This time to sync is dependant on your network speed, but typically I see it work in 30-60 seconds. If you want to force this, you can always do a restart of the device. It will sync upon boot up.

I hope that helps and gives the community a quick answer to one of our most common questions.