[SOLVED] Home Assistant - no settings in home.mycroft.ai


I am running a new installation of Picroft.
I have installed the home assistant skill manually (msm install https://github.com/btotharye/mycroft-homeassistant.git). msm list tells me it is installed, however I cannot find the settings in home.mycroft.ai

According to the git page, “This skill utilizes the skillsettings.json file which allows you to configure this skill via home.mycroft.ai”… However I cannot find this file on my system, I am guessing that’s where the problem is.

Any ideas on how to fix this?


Ok… According to the log, the skill does not start (which explains why the settings area is not created on home.mycroft.ai) because the module fuzzywuzzy is missing.

After entering the virtual env (source /opt/venvs/mycroft-core/bin/activate) if I try to install it I get this:

(mycroft-core) pi@picroft:/var/log $ pip3 install fuzzywuzzy
Collecting fuzzywuzzy
  Downloading https://files.pythonhosted.org/packages/d8/f1/5a267addb30ab7eaa1beab2b9323073815da4551076554ecc890a3595ec9/fuzzywuzzy-0.17.0-py2.py3-none-any.whl
Installing collected packages: fuzzywuzzy
Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/opt/venvs/mycroft-core/lib/python3.4/site-packages/fuzzywuzzy'
Consider using the `--user` option or check the permissions.

(mycroft-core) pi@picroft:/var/log $ pip3 install fuzzywuzzy --user
Can not perform a '--user' install. User site-packages are not visible in this virtualenv.

Suggestions? I guess I need to be root but I’m not sure how to combine that with the virtual env.

1 Like

Ok, problem solved lol… I just installed fuzzywuzzy with sudo outside of the virtual env, rebooted and the skill loaded, the settings are now present in my account…

A few things to check here;

  • Is Picroft paired successfully?
  • If you do a Shift + F5 refresh on home.mycroft.ai does this help at all? home.mycroft.ai uses some caching at the server level.
  • In the Skills log at /var/log/mycroft-skills.log are there any errors related to the Home Assistant Skill?

Best, Kathy

Hi Kathy
Thanks for the reply, but I have already solved that problem - fuzzywuzzy was not installed so as a result the skill was not starting at all, which is why the settings area had not been created.

1 Like

Great detective work!

I’m getting used to this by now :stuck_out_tongue:

1 Like

fuzzywuzzy solved this, maybe it should be included in the next picroft :slight_smile:

That didn’t solve it for me. “Fuzzywuffy allready installed”, the skill install seemed like a success. But, no Home Assistant appears in the “skill settings”.

Can it be this?:

BTW I’m using danish lang. RPi3b+ Picroft

When trying to delete the skill “msm remove homeassistant”, results in:
MultipleSkillMatches: homeassistant, homeassistant