Skills not loading / Please wait a moment as I finish booting up

Hello community,

I’ve recently set-up a Picroft installation (unstable) and successfully configured to use with MATRIX Voice board on a RPi3B+, also installed the openHAB skill.

I’m experiencing strange boot-up behaviour as onla 1 out of 3 attempts seem to work (pulling power after a few minutest to try again). Once it booted up OK it seems to be stable. Not sure where to search for the problem, my power supply is a quality one.

Much worse however: since a boot-up today it seems that no skill is loaded. I see the cli and mycroft listens to me and the proper words are displayed. However, the only answer I get is:

Please wait a moment as I finish booting up.

When I try “: skills” there seems to be no skill installed (empty list).

What are the debugging steps for this?


The first point of call is always the logs.
They should be available at /var/log/mycroft/*.log.
Start with skills.log and see if that provides any clues.

Here is the latest of the skills.log:
What do I look out for?

I’m also getting a strange result here when I try mycroft-msm update:

(.venv) pi@picroft:~ $ mycroft-msm update
MsmException: Invalid branch: 18.08

So, a couple of things here @SpaceGlider.

Skills not loading

I had a read through of the log provided (thank you) and there were lots of Git popen calls, which suggested that - as expected - Mycroft was trying to update Skills on boot. Some of those calls resulted in Git errors - this may be as a result of any Skills that have been locally edited. Are there any Skills that have been manually edited? If you remove that Skill do the other Skills load? One Skill shouldn’t prevent other Skills from loading, but it’s something I’d like to rule out.


The code that throws this error is here;

What it is trying to do is check out the origin/18.08 branch of a Skill. Again I think this may be related to any custom Skills / modified Skills you may have on Picroft.

1 Like

Hello, I only installed the “openhab” skill.
I think I did it through the command line/ssh and then also through the web interface.
It did work!

But maybe I should remove it? How do I make sure it is completely removed?

Right, to make sure it is completely removed, go to your command line and look at the /opt/mycroft/skills directory;

ls -las /opt/mycroft/skills

This will show you which Skills are installed on the filesystem.

You can then remove the Skill you want to remove by doing;


rm -R openhab

OK I did this and rebooted, but no luck.

These are the installed skills:

(.venv) pi@picroft:/opt/mycroft/skills $ ls
fallback-unknown.mycroftai               mycroft-joke.mycroftai              mycroft-stock.mycroftai
fallback-wolfram-alpha.mycroftai         mycroft-naptime.mycroftai           mycroft-stop.mycroftai
mycroft-alarm.mycroftai                  mycroft-npr-news.mycroftai          mycroft-support-helper.mycroftai
mycroft-audio-record.mycroftai           mycroft-pairing.mycroftai           mycroft-timer.mycroftai
mycroft-configuration.mycroftai          mycroft-personal.mycroftai          mycroft-version-checker.mycroftai
mycroft-date-time.mycroftai              mycroft-playback-control.mycroftai  mycroft-volume.mycroftai
mycroft-fallback-duck-duck-go.mycroftai  mycroft-reminder.mycroftai          mycroft-weather.mycroftai
mycroft-hello-world.mycroftai            mycroft-singing.mycroftai           mycroft-wiki.mycroftai
mycroft-installer.mycroftai              mycroft-speak.mycroftai
mycroft-ip.mycroftai                     mycroft-spelling.mycroftai
(.venv) pi@picroft:~/.mycroft/skills $ ls
AlarmSkill          IPSkill           PairingSkill            SkillInstallerSkill  SupportSkill         VolumeSkill
AudioRecordSkill    JokingSkill       PersonalSkill           SpeakSkill           TimerSkill           WeatherSkill
ConfigurationSkill  NapTimeSkill      Playback Control Skill  SpellingSkill        TimeSkill            WikipediaSkill
DuckduckgoSkill     NewsSkill         ReminderSkill           StockSkill           UnknownSkill         WolframAlphaSkill
HelloWorldSkill     PadatiousService  SingingSkill            StopSkill            VersionCheckerSkill

Still the same “Please wait a moment as I finish booting up” and empty list under “: skills”

Edit: show the output of both skills folders…

Thanks for the useful diagnostic information @SpaceGlider, really appreciated.

I’ve conferred with my colleagues (many thanks @forslund) and we think that your
directory may have become corrupted.

Are you able to delete this directory by doing;
rm -R /opt/mycroft/.skills-repo

and see if this works?

The ./skills-repo will be automatically rebuilt by Mycroft.

1 Like

Yes! It worked! Thank you so much for the amazing support @KathyReid

For the record, I had to use the sudo command to remove the repo:
sudo rm -R /opt/mycroft/.skills-repo

After that a reboot did it.
Now to play around some more :slight_smile:

That’s interesting information. I wonder how the rights got changed… (since the folder should be owned by the pi user)

Incorrect ownership of the .skills-repo would probably result in this sort of issue.

Did you by any chance install some skill from the command line using sudo? or start mycroft with sudo?

1 Like

Hello @forslund,
unfortunately I didn’t save the outputs of the command line, but as far as I remember there were a few (maybe 5ish) files which couldn’t be deleted without sudo.

I might (and I’m really not sure) have tried to install the openhab skill with sudo.
I certainly have never started mycroft with sudo. (I couldn’t even find the command line commands to start/stop mycroft without a reboot. maybe add this to the documentation!).

Thanks anyway spaceglider, it’s much appreciated. We’ve done some thinking and proposed a possible fix for this sort of issue. so hopefully your suffering will allow future generations a smooth experience :slight_smile:

1 Like

I had this exact problem (which also coincided with yellow eyes). I did the sudo rm -rf /opt/mycroft/.skills-repo (sudo was required for me as well) and it cleared everything up like magic. Of course I didn’t read to the bottom of this thread before I nuked everything and restarted, so I don’t know which directories had permissions changes either. Just thought that I’d mention that I did experience the same issue so you know it’s not an isolated issue that just impacted @SpaceGlider.