Skills marketplace down for picroft?

Hello, I’m new to mycroft and thought I’d install it on my raspberry pi by using picroft. Everything worked perfectly including the device registration, but then the skills marketplace is blank and when I try to view my already installed skills, it lists none, not even the default ones. Is there any way I can correct this issue or is on the developers end?

Also, on a somewhat realted subject, I tried to overcome this issue by installing mycroft for linux on raspbian. This actually worked pretty well. I had to skip creating a local version of mimic because the raspberry pi doesn’t have enough memory, but mycroft installed fine. I was able to give it commands over the microphone and manage skills at The only issue was that mycroft won’t output any audio. It responds to my commands and I can see its repsonses in the debug mode, but there’s no sound. The little chime when I say the wake word doesn’t play, and when I play the news from npr, there’s still no audio.

I’m using 3.5mm headphones, and they work fine when I run a sound check. Interestingly, if I install pandora on mycroft and play music, it plays just fine. It’s only mycroft itself and the news that don’t output audio. Has anyone encountered this issue? After some googling, I came across one thread that suggested this might be because I skipped creating a local mimic, but I’m not sure if that’s true. Thanks!

Same here. Just installed it on a pi and was wondering why there are no skills listed at all. But I am also new to Mycroft so maybe we are both missing something … ?
But for your raspbian installation you see the skills, right?

Hi @kiedan and @wkjben
It isnt you, but there is a problem in the backend, so skills arnt showing up :frowning:
I have heard there is work going on to locate the problem and fix it.

Yes, skills show up for the regular installation of mycroft (not picroft). I’m just dealing with the audio bug now.

@andlo thanks for letting us know
@wkjben so I followed your footsteps and went for a fresh raspbian installation und the skills work fine now …
But gues what doesn‘t: no sound output for mycroft or news while playing spotify works fine. :sweat_smile:
Did you manage to fix it in the meantime?

No, there’s no error message, so I’m not sure what to troubleshoot. The only thing I could think to do differently is a fresh install and build a local mimic, but my raspberry pi doesn’t have enough memory for that.

So, I actually made some progress. I installed mycroft on raspbian buster and went through the setup, skipping the mimic build. When I went to register the device at, I set it to Google voice, and it worked! If I change it back to any of the other voice options, it doesn’t. Anyway, mycroft is working perfectly now on my raspberry pi. I actually prefer this to picroft because I can keep raspbian and still use my pi to run other programs. Plus, I don’t know if they ever got the skills page back up and working for picroft. It’s pretty easy to set it up so that mycroft launches on boot up too, so it’s virtually identical to picroft.

It is for all intents and purposes identical to Picroft, it’s just that Picroft is sorta optimized/tweaked/ready-built for Pi (bugs aside.)

If you “installed Mycroft” (terminology’s fine, just in quotes because there is more than one image out there) you probably installed a recent release from the same repository developers use to work on Mycroft.

There’s no particular reason you need to know any of this, except to know that Picroft is Mycroft is Picroft is just Mycroft tailored to run out of the box on Raspbian (edit: as a dedicated device, generally, like a DIY version of the devices Mycroft makes.)

Hello I have also the same problem and maybe it’s that why I can’t run spotify skill :frowning:

I too am not seeing all of my skill settings in the marketplace. Looks like this bug has been open for some time. If there is anyone following this at MyCroft, could you provide any status/info?
I should also mention that if I modify a skill setting and then tell mycroft to “update config”, mycroft responds with “no changes to apply”.


Linux picroft 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l

This page is empty?

@j1nx, not sure if you are directing the question to me but assuming so…
No the page is not empty. Several skills are listed. However, not all of my installed skills show up. For example, I have installed a roku skill and a new “mesh” skill: neither show up in the skill settings list. The Roku skill did show up about a month ago but it has since disappeared. Also, when I modify any skill setting, that modification never makes it down to my mycroft device. I tested this with the “Set Alarms” skill, changing preferred alarm to chimes. That change is never pulled down to my device.


Right! I believe you are running Picroft isn’t it? There were some skill gid changes recently that had to do with the syncing of skill settings.

There must be some mechanism that left you (and others, because I noticed similar monkey business reports from other users) hanging somewhere in the middle.

I think it is best to ping @gez-mycroft and @forslund. They should be able to pin point the issue and hopefully solve it for you, the others and otherwise others to come.

1 Like

Hey Ben,

Can I ask what Picroft image you used to get setup?

I’ve had a few people with similar symptoms tell me it’s working again after using the latest 2020-01-10 image. You can grab that here:
SHA256: 9cd9ec16388d72dfc6069bc7ea62d1b73e944df103571f48c88a49ec09f5f6d4

I Thanks you to answer but I’m not ok to use an unstable sofware or beta etc .


Hi Witanix,

Good news, we’ve just promoted the fixed image to Stable following its review period.

You can get that from:

Hello Gez thank you for the news. Is it possible to Just upgrade my installed system and not burn another image to sdcard ?