Skill submission - difficuties with github

I have a skill coded and ready to go. I have created a repository on and have been trying to follow the directions in the docs but have been tripped up by not really understanding the steps.

  • I cloned the Mycroft skills to a directory on my hard drive.

  • I made a submodule in that directory and confirmed changes to .gitmodule

  • On the repository page for my skill I click New Pull Request and enter ‘MycroftAI/mycroft-skills/master’ on the left and ‘GitHubUsername/mycroft-skills/master’ on the right but always get "There isn’t anything to compare "

I don’t see how the clone and submodule sitting on my hard drive have any effect on the process. Do I supposed to do a commit from the directory where the clone is? I tried that.

Could someone connect some dots for me on how the steps fit together?

Did you use msk to help create and submit? That’s the current preferred method for submission.

Definitely try msk upload instead; the Skills docs are woefully out of date (my bad).

Thanks for the responses. Reporting back to say that I used the msk and submission went pretty smoothly.

The reason I did not use it in the first place was that I created the skill by copying an existing one so did not need msk to create all the directories and folders.

I followed the directions under “Upload Skill” on the page linked above. The only rub was getting an error on the first try because I had not set my github identity with git config (username and email, I think). After doing that I ran msk again and it was smooth sailing.