Skill conflict or mycroft wrong understanding? Philips HUE


I have run the Philips HUE skill from GitHub - ChristopherRogers1991/mycroft-hue: A Mycroft skill for controlling Phillips Hue lights since the beginning of my delivery of the Mark I.

It has always (almost) worked OK. If it for some reason hasn’t worked, mycroft has always replied “I don’t understand but I learn …”. But now (starting this Wednesday) when asking “Turn off the light” as I say every morning when leaving to work… It answer “There’s no timer set”.

Just checking to see if he understand me at all I ask about the weather. And yes that Mycroft understand perfectly.

So to the question related to this.

  1. Whats wrong?
  2. Is it on my device or can it be in the cloud? The interpretention of voice isnt that handled in the cloud?
  3. Why isn’t HUE part of the skill list anymore ? I found it only on Christopher Rogers github not on the mycroft-skills github?

Thank you for the help!

/Lars (that needs to use the buttons for now to turn of the light …:frowning: )

If you haven’t updated the skill lately, might be worth doing that. There was an issue with the group names making it difficult to turn things off he fixed a couple months ago.

The logs are also very helpful for troubleshooting, they should reside in /var/log/mycroft, peruse and see if you can find something related?

Hi Lars,

This was likely caused by a typo in the timer vocab which was then reporting a higher confidence level and taking priority. It got fixed overnight so please let us know if this continues after your skills update.

You can force an update with mycroft-msm update.

Yes! Thanks now it works! Puuh I started to get pain in my push finger for the on / off light buttons … :slight_smile:

:laughing: it’s a hard life!!!