Site HTTP -> HTTPS forward not in place

Hello, first I’ll say I love what you guys are doing with Mycroft!

When I first tried to visit, i typed into my address, naturally it defaults to http instead of https. I would recommend telling your Ubuntu Apache server install to redirect http to https. The site does not display properly under http.

I ran into the same issue with the activation email link.

I have been considering make a post about this myself. I really like that HTTP traffic is dropped, but it’s not really elegant to then not redirect, particularly for our less technical users

@crash4fun @eraptic great feedback! I’m not seeing this issue as the redirect is working on my browser. What browser are you guys seeing this on? What OS?

I’m using Vivaldi on Arch Linux. Just tried again and I can only reproduce when there’s no url schema as in A friend of mine also had the same issue on his Android phone and OpenSuse Tumbleweed

@Arron_Atchison interesting issue here, let’s see what we can figure out.

Alright @eraptic @crash4fun - I made some changes to the proxy - let me know if you are still experiencing the issue.

@ryanleesipes The issue is still happening, I’ve tried it in Firefox in Ubuntu 14.04 (most recent version), Chrome Beta channel for Linux and Chrome 47 for Windows 10. Visit by typing directly into the URL bar.

This is very strange because all of my browsers redirect; Chrome, Firefox, Vivaldi, Lynx, Elinks – on Linux and OSX…
Maybe we could co-ordinate a log inspection effort @crash4fun? I’m sorry that you are experiencing issues.

Ryan and I were able to recreate the problem when using Chrome in incognito mode.
For anyone that would like to know, the problem was that
RewriteCond %{HTTPS} on
should have been
RewriteCond %{HTTPS} off
in the virtual hosts file.
Can you confirm for me that is works for you?

Working on all of my browsers now :slight_smile:

1 Like

Thanks so much to everyone who helped us troubleshoot this!

I can confirm it works proper on my end now, glad to help.