Setup does not move forward when attaching to a WPA3-SAE SSID

Description of the problem:
Initial setup - not compatible with WPA3-SAE SSID, probably more Raspberry pi related than Mycroft Mark 2 software.

Tested on model SXR80 router aka Netgear Orbi Pro with multiple WLANs and SSID configured.

  1. Fails - When pasting the password for the WPA3-SAE SSID the Mark 2 doesn’t connect and returns to the beginning of the setup.
  2. Pass - When pasting the password for the WPA2-PSK SSID wifi setup occurs as expected and proceeds to pairing.

Both are dedicated and not mixed types.

Steps to reproduce the problem:
*For example, *
- Plug in fresh Mycroft Mark 2
- Mark 2 creates Wifi hotspot - “Mycroft”
- link device to wifi hotspot
- Select WPA3-SAE SSID
- Enter WP3-SAE SSID either manually or copy paste from password manager
- submit the password
- "suspecting cause of restart is a timeout of the authentication to start the process over

Any changes you have made to the device?
- No, fresh out of the box, texted on two different Mark 2 devices

Anything else you can think of that might be helpful?
If this is reproducible by others it may be wise to add a note of the Wifi limitation in the setup until this is worked out on

-Work around is to use a WPA2-PSK SSID

If the Pi itself can connect to WPA3 (which there seemed to be disagreement on in issue #4718 that you linked) - then it’s possible you could get it connected by creating the right connection configuration.

I did a little write up of what this might look like for WPA2-enterprise here but I haven’t tried it

I’ve added a warning to the setup instructions as suggested too, thanks