Settingsmeta.yaml not showing text boxes on website, also skill duplicates (including previously removed ones) still appear


I got an issue with settingsmeta.yaml, even though I tried making it like this:
name: Sleep Tracker
- name: Birth Date
- name: year
type: Number
label: Year
value: “”
placeholder: 1993
name: month
type: Number
label: Month
value: “”
placeholder: 12
name: day
type: Number
label: Day
value: “”
placeholder: 16

The issue is that the textboxes did not load, even after an “empty cache and hard reload” on the browser.

Also since I tried to reinstall the skill due to a merge error when attempting to update, I end up with duplicates like this:


One thing that strikes me is that the type fields in other skills are lower case characters only so try changing Number -> number . The skill page is very new we might have some bugs still so if it still doesn’t work let me know and I’ll look into it deeper.

I’m going to create a test skill tomorrow to run through all the specified types to see if verify myself as well.

Thank you very much for reporting this, and hope the issue is a simple capital letter otherwise let me know and I’ll dig deeper.

  • Åke


The lowercase ones worked, and each field should be prefixed with a dash (-) when using yaml. The wiki was a little confusing since it allowed uppercase.
Is there an option to put a dropdown on the yaml like on the JSON ones?

Great to hear. All options supported by the json should be supported by the yaml. I’m not 100 % sure about yaml syntax but it should be something along the lines of:

name: Mycroft Weather
      - name: Units
          - name: units
            type: select
            label: Temperature units 
            options: "Default (from Basic Settings)|default;Celsius|celsius;Farenheit|farenheit"
            value: "default"

Also feel free to correct the issues you’ve noticed on the wiki :slight_smile:

I have noticed that the settings duplicate also. This was happening on the previous version also though. I use json for my settings.

Dropdown worked on the sample you gave. Thanks @forslund
Edit: It would be nice if they also allowed a selectable calendar to be on the skill settings, especially those skills that use a specific date as a reference (like sleep trackers).

Nice to hear I’m very lucky today (if only I’d bought a lottery ticket).

I’ll talk to the server people of adding a calendar type but that will have pretty low priority for the coming weeks while we iron out the kinks of the newly deployed backend.


  • Åke

A bit of an update the capital Number, Text etc were supposed to work but the webpage didn’t render them. I think the code is updated now to handle it.