Setting up my new PiCroft project: sudo, ssh and authentication warning

Hi all,
I am new to Mycroft, and was trying to install it on a Raspberry PI 3 using the PiCroft image.
However, I encountered few issues I couldn’t find an answer for.

  1. I tried to use su/sudo command, and also tried to connect via ssh to the device.
    none of the passwords I read on the forum/documentation worked. I understand that I should use the user ‘pi’ to ssh, what is the password for that user?
    I also understand that the PiCroft package came wit some skills owned by mycroft user (on the file system), but when I am installing a new skill through msm command line, it seems that I can’t delete it because it is owned by ‘root’ user. Is that by design?
    So what are the passwords for the users: root, pi, mycroft?

  2. I have the following warning:
    mycroft.configuration - WARNING - Failed to fetch remote configuration: HTTPError(u’The supplied authentication is invalid’,)
    Why does it show up? how can I fix it?
    I already paired the device and set my location at

Thank you in advance,

Re: question 1
You can SSH using the user: pi
…with password: raspberry

As user: pi …you can also use: sudo

Thank you :slight_smile:

Hi, @Servo . Did you find any information related about mycroft user’s password?

Thank you.

Hi @Joseten, how to ssh to the Picroft is documented here

Thank you about the information @KathyReid, but i was reffering of the user named “Mycroft” at the /etc/passwd file. This one exctly: mycroft:x:1001:1001::/home/mycroft:/bin/bash

I wanted it to let Mycroft update my system. In any case I changed that password by root and all seems to work fine. :smile:


1 Like