Setting up audio when doing Linux install on RaspOS

Hi all,

I searched the forums but couldn’t find anything, and I could be having an idiot moment, but I didn’t see anything about it in the Linux install docs. My Linux experience is pretty solid. I deploy and secure virtual hosts and libvirtd vm’s (qemu/kvm). I’m an EL Linux user primarily (rhel and CentOS) but I’ve used debian enough times, and now that it’s using systemd, even better.

I built my Mycroft with a Pi 4b 4gb and ReSpeaker Mic Array v2. I’m using a Logitech Z50 for the speaker, plugged into the 3.5mm jack on the ReSpeaker. My first test run was done using the PiCroft image, and everything worked great! I then decided I wanted to do a custom install onto a RaspOS image that came from my lcd screen manufacturer (800x400 4" IPS touch from Amazon… MazerPi) since the standalone driver gave me an issue at first, and I wanted to use the display, and after a reboot of PiCroft, I got stuck on unable to connect websocket for the client.

so I installed the image, cloned the mycroft-core repo, followed the instructions and did the ‘bash’ install. Created a service file. Mycroft started up without issues, I enabled the service and rebooted. Client loads up fine, all services start fine. But I can’t for the life of me figure out where to configure the audio for mycroft, to use my ReSpeaker mic array and it’s 3.5mm jack.

So that’s where I’m at… I’m sure it’s something simple. Anyone able to help me out here? Thank you, and sorry for the long winded story for a simple question :slight_smile:


1 Like

I have a very similar setup, and I solved this problem…but a couple of weeks later I have the same problem and I have forgotten how I solved it. Something to do with:

pulseaudio --start



I really should have written it down…sigh

1 Like

Hey there - here’s the bit of the script that runs when a user selects the Respeaker Mic Array on a Picroft install:

I’d suggest using that firmware. Though I’d also suggest setting it as the pulse audio default rather than the custom play commands that picroft uses. Either way should get the job done though.

1 Like

Thank you gez. I don’t know why I didn’t think to check the existing script. As I’m doing some testing on a buster based image I’m likely going to break again, I will likely pull those changes and any other section not already handled by the script, and drop them into a new script, and add a an ifexists call to it in dev_update, and push the changes for review once finish it. I may also build an updated PiCroft image since the current one in the docs is 20.08. I wish I knew about the diy installs before (when I found mycroft last year, I reserved a mk2 but didn’t visit the forums or bother to see if it could be used without buying a mk2). At least I know now, thanks to the devkit email which brought me back to the site. This is my first pi ever. All my other projects either use arduino leonardo clones, esp8266 or esp32 NodeMCU boards, or run in a VM on my x86 nuc clone server. I’m not new to Linux but there’s still some learning going on with pi vs full blown x86_64 distros.

On a side note, since I’m here already, does the mk2 devkit run mycroft_gui with core together? I was going to do this with my setup but the installer script for the gui has a visible output line stating that core needs to be run from a separate host, so I wanted to do some more research into this.

Anyway thanks for the response!


Currently the Mark II runs mycroft-core and mycroft-gui in the same container. This will likely change but is absolutely possible.

There are however dependencies that aren’t available in Buster. I’d recommend a Ubuntu 20.04 base for the easiest setup.

1 Like

Thank you! Much appreciated