Set Volume doesnt appear to actually adjust volume

Using the set volume command doesn’t appear to change the actual volume. rpi3+, latest master clone, pulseaudio, respeaker mic array v2 (speakers via headphone out). If watching alsamixer the Master gets updated with the respective setting from the command but the spoken volume from mycroft never changes. Tried few other things like setting pulse volume via cmdline and can see the change in pactl info but still same volume when mycroft speaks.

EDIT: Just noticed the set volume will change the volume of say pandora or spotify but the speech from mycroft always remains the same. Maybe I’ve just totally missed a config option or something.

Any ideas?

1 Like