rPi Setup and operation

I have tried several times to set up PiCroft and am having some challenges. I am downloading the standard picroft-wip-20180119 image from the web.

After booting the update fails with a sleep command failure in bash, but this can be interrupted. A reboot appears to boot and (on the third attempt) I paired he machine.

Now I have a constant stream of DEBUG outputs, speech client failures and green text that produces a beep and a message that the wakeword is detected and end recording, even when silence pervades.

I have tried different downloads and different cards to burn the image too, but each fails - not always in the same way. I’m waiting to see if there are logs I can pull before simply reformatting and starting over.


Logs for the picroft are in /var/log, prefixed with mycroft-. Are you using a custom wake word or other custom configs?

Hi there @grahambb sorry to hear you’ve had these issues. As @baconator said, we’ll need some logs to assist further please.

We’ve also seen a stop-start of the mycroft-skills service have positive effects as well;

sudo service mycroft-skills stop && sudo service mycroft-skills start

Kind regards,

I tried a custom wakeword, but reverted it to the standard. I’ll pull up the logs and add them to this thread.

When I booted up to get the log files, I was asked to pair the device again. :-((

Logs are here: Dropbox - File Deleted - Simplify your life

I keep getting asked to pair my device as well. Perhaps something is up on the back end?

Thanks @gov, yes this was a backend issue, this should now be resolved.

1 Like



I checked this am( ~8:00 am EST ) and all was well again.



1 Like

awesome, thanks for confirming

@KathyReid are these log files of any use?


Well, I guess that sums up the usefulness of the Forums as a support channel…

No need for the sarcasm, I think you’ll see that we’re pretty responsive in general. My understanding of this thread was that the issue was resolved because we had a back end outage - therefore there was no need to look through the logs. Is the issue still occuring? And are the logs you provided a while back still valid?

Best, Kathy

@KathyReid The issue had nothing to do with the backend outage, this thread was ‘hijacked’ by someone else raising that issue. I submitted the files and sent a follow-up message asking if they were useful.

That follow-up message had been ignored for 24 days before my comment.

I deleted the files yesterday, will download the latest image (is the 3/14 image available, I have been travelling for a while and haven’t rechecked recently?) and I’ll start from scratch again.


The latest Picroft image is available at https://mycroft.ai/to/picroft-image

Thanks for the update!