RPi analog audio hangs , alt speaker options

Following comments by @aatchison last week that there was a known issue with the analogue audio output ( i.e. the headphone jack in the rpi board ) and
rpi cmd aplay hanging after a number of “plays”, i’ve been looking at speaker alternatives.

Today I tried a “USB 3D 5.1 Sound Card” with a Rpi3

Previously I had added a PS3 Eye camera and a wireless keyboard are usb accessories, running official pi3 power supply,

The combination of the both of them on the power supply of the Rpi meant that only one would function.
That is only the Sound Card would work.

So I have had to a powered usb hub to run the PS3 Eye camera on the powered hub. Something similar to:

Rebooted and the Mycroft server has been running fine with no Audio hangs
and a “hey mycroft what time is it” completes in about a couple of seconds.

Update to the above config - rpi / ps3 eye / 3d usb sound card

Powered on today and went thru usual auto update process.
Now Mycroft will not respond to wake word.
test_microphone util records and plays voice.
Have tried disconnect all components and reconnect but still no wake work response.
Version on boot is 0.8.3.

Any ideas ??

.only thing i can think of is RPi power supply issues but as test_microphone util works cant see how that is valid

Have rolled back rpi mycroft to a 3.5mm speaker and the ps3 eye
as the USB sound card and the usb powered hub seem to conflict sometimes with mycroft … intermittent un-diagnosed fault.
The USB sound card should work , maybe with some alsa config changes according to some rpi blogs.

Mycroft now running this version 0.8.5 core … which has the beep and has a fix for aplay hang, so all working again as far as mic input and audio.
“coreVersion”: “0.8.5”,
“enclosureVersion”: “0.1.21”


Glad to hear that fixed your issue. I was curious.

yes appears to be the good old Rpi PSU issue