Raspberry Pi First boot network setup


I am new to Mycroft and this forum. I have flashed the image to an sd card and booted up while connected to a display and wifi adapter, but I am unable to connect to the MYCROFT wifi network with the password MYCROFT1. Also, the code on the screen does not work on home.mycroft.ai. Please help me connect to wifi! Thanks.

Are you using the Raspberry PI 2, or the 3 with the built-in WiFi? Are you seeing the MYCROFT network when you try to connect to it?

Can you try re-downloading and flashing your PiCroft image? There was an issue with the WiFi setup, but if you download it now it should be fixed.

You should also be getting the code after it’s connected to WiFi, not before.

Thanks for the reply. I am using a model 2 with a wifi adapter. I can see the MYCROFT network but when I try to connect, it never does. Is the latest image in the blog post or somewhere else? Thanks

It’s in the blog post. That link should be current. Try that and let me know if you are still seeing an issue. Also, one thing you can do is look at the log for errors. You should be able to find it in

I looked in the logs, and the configuration file /root/.mycroft/mycroft.conf file does not even exist. I have pasted in the contents from the github conf file but am still unable to connect to the mycroft wifi network. Thank you for your help.

If your startup screen says 0.8, then you have the image that was first posted which has a bug that broke the wifi-setup process – once you jumped to your browser, after connecting to the MYCROFT temporary network, it would wait forever. When we realized that problem had slipped in, we replaced the 0.8 image the next day with a 0.8a image that corrected the problem.

The image version shows up in some lines like this that appear in the console output:

** Picroft development image, v0.8a       **

If you have the “0.8” instead of “0.8a” and are trying to use wifi network, you should pull down the image again from: https://rebrand.ly/Picroft-0_8

Future issues will be corrected via an automatic update that the image will download. But we needed to modify the image itself to make sure you can get on the network before those can be pushed out.

I have been using that image. My computer won’t even fully connect to the MYCROFT access point.

So one thing you can do is manually connect the Raspberry Pi to your wireless network and skip the connect to the access point step.
A good guide to do that is here:

You can skip down to modifying the wpa_supplicant.conf file and just put your wifi info there. You should see a few entries already for the “MYCROFT” network.

I am curious what issue you are having though, as that step should be working with the newest image, so if you can let me know any other info, like if another device can connect to that MYCROFT network, that would be great. It sounds like you’ve been trying this for a while now and I want to get you up and running.

Thank you both for all your help. After I manually connect to wifi, do I have to bother about the code or is that not necessary?

You do still need to enter the code. It registers the device so it can connect to the servers.

Hooray! My mycroft is working, though each time I turn it on, I have to setup a new device on the web ui with a new code. I can live with that for now, appreciating that it is in a development state, but is there a workaround so I dont have to set it up each time? Thanks.

We’re working on that now, but Steve knows more about the release time for a fix. As for a workaround, you can try
sudo nano /home/mycroft/.mycroft/identity/identity.json2
and save it as
To save, just hit ctrl+o and change the name and then Y when the prompt asks to save the file under a different name. That should fix the re-register issue for now.

1 Like

Awesome. You guys are the best. Thanks for answering all of my questions and keep up the good work.

Awesome! Glad to hear it’s working. Play around with it and start tinkering.

Hi @Karl, I have a similar problem on first boot.

Mycroft runs and says logon to MYCROFT network and enter MYCROFT1 and then proceed to start.mycfroft.ai, to setup wifi. (cool my Pi3 is talking to me)

The output on the screen says that …/configuration/mycroft.conf loaded
etc/mycroft/mycroft.conf loaded
home/pi/.mycroft/mycroft.conf not found
then after retries
sending message…‘mycroft.wifi.start’

then the same as the verbal msg “logon to MYCROFT network etc”

I have a photo of the screen if you need it
I am on ver 8a

I have tried


“sudo iwlist wlan0 scan”

“sudo nano /etc/wpa_supplicant/wpa_supplicant.conf”

I recieve no response from the command line.

I’m stuck I have reached the limit of my ability to pretend I know what Im doing by copying others that do:D

update: used a cable, success, I am now talking to Lester, my new mycroft ai pi3. He only says I did not catch that at the moment.

Glad to hear you got it working.

Just to verify, you tried connecting to your Raspberry Pi with another device, right? It should have put up a WiFi Network with the name MYCROFT, password is MYCROFT1. If you use a mobile device, you should get a prompt to logon to the network, but either way you should point your browser to start.mycroft.ai and follow the instructions. That process should be fixed with the .8a image.

Either way, it sounds like you got it working, so keep us updated on your thoughts.

@Point, I think we didn’t direct you well to how this works. The process involves using a secondary device to configure the Wifi on you Raspberry Pi. For example, I use either my Android phone or an iPad to do this.

Basically the steps should be:

  1. Fire up Picroft and get it to the point where it says “logon to the MYCROFT network and enter the uppercase password MYCROFT1…”
  2. On you other device, pull up the Wifi settings and look for the network with an SSID of “MYCROFT”. Connect to that with the password “MYCROFT1”
  3. If you have an iOS device it will automatically fire up your web browser at this point. If not, you need to start your web browser and browse to http://start.mycroft.ai
  4. You will be presented with a list of Wifi networks that your Raspberry Pi can see. Pick one and enter the password. This exchange is only happening between your mobile device and the Raspberry Pi (I can point you to the source code if you want to verify!) so your password is safe.
  5. Once you get the confirmation, the MYCROFT network disappears and your Pi should be connected to the network.

Let me know if that is unclear and if it works for you. Perhaps we need to be more explicit in our directions.

Hi @steve.penrod Steve, Thx. Basic is what I need :smiley:

I have a few tasks atm, so I will just clarify.

  1. No wifi.(pi croft has discovered the router, but I get a msg daemon failed to start)
  2. SSL need to re-register on reboot (subject to change after update.)
  3. No recognition from Mycroft - “I’m sorry I did’nt catch that” (no longer.)


  1. I have used a cable for ethernet, will solve that problem later.
  2. I removed the request setting, (see below)

_If you want to get it working right now, we’re trying an update to _
the SSL version and modifying the config file. If you want to try it,try
sudo pip install requests -U
sudo nano /usr/local/lib/python2.7/site-packages/mycroft_core-1484348707-py2.7.egg(or just hit tab)/EGG-INFO/requires.txt

and remove the “==2.81” after "requests"
So “requests==2.81” becomes “requests”

I have just rebooted PiCroft (Lester) and
he has download the update you have done. I now have a working unit, I have to set the localisation, because he is giving me Kansas info. Wahoo.:penguin:

  1. When I looked in my (android 6.0.1) network settings, MYCROFT is not there, I logged onto home.mycroft.ai using firefox on win 7. Pi does appear on Asus wireless (of Course).

I have just used my android to logon to “home” and mycroft has responded to a request for the time, its 9 in Kansas.

Directions are great, when I recieved instruction to logon to MYCROFT network I checked my android and found no network, so that made me think I was doing something wrong.

I think if I can get it working, then the directions are excellent. Patience and the knowledge that you guys are working feverishly behind the scenes to make it work, without me knowing anything, is how I am approaching this. I’m also learning alot of cool stuff.

On reboot, after setting time and localisation.

I have msg.

This unit needs to be registered etc. But there is no code this time.
Also at the end of the log
Warning access denied at mycroft.ai
Utterance: Pair my device
Speak: Your device is paired and ready to use

Mycroft no longer responds to skills, except to repeat the line above this.

I ran sudo update and sudo upgrade, hope this was OK, updated a lot of files.

With the current image, every time you reboot you have to re-register unless you fix the issue. We’re working on getting it fixed in a new image and I’ll let you know once it’s tested (by me).

If you want to see the fix, check out this post above: