Pycroft Up and Working (with some Caveats)

I just set up my first Mycroft device (on a Raspberry Pi 3 B+). Took a bit of tinkering:

Audio Problems:

At first, the speakers worked, but the microphone didn’t (Blue Snowball). So I installed Pulseaudio, and then the microphone worked but the speakers didn’t. Turns out the speaker volume is just set all the way down on reboot now for some reason. I tried playing with the Alsamixer and Pulseaudio settings and have tinkered with a few config files, nothing helped. Then I updated Mycroft (using “bash”) and that fixed it.

Then I switched from headphone jack output to hdmi as my audio output and the speaker volume problem came back. After spending a few hours today troubleshooting, I have given up and decided to just turn the volume up after each reboot. Not a big deal I suppose.

Pandora Problem:

I’m getting a “Password or Username not correct” error. I’ve tried uninstalling the skill, rebooting, and reinstalling. Didn’t help. Did a bit of searching on this forum though and it seems this is a common problem for a lot of people that has yet to be resolved? Any update on this?


All in all though, I’m liking Mycroft a lot. It’s been fun to tinker with, the speech recognition has been spot on, and the skills I’ve tried have worked really well, except for Pandora and Reminders (for some reason, all of my reminders are set for midnight, but I haven’t played with this much yet). Going to test the other skills this week, and then build a custom Pycroft enclosure setup. Might try my hand at programming a skill at some point just for fun.


That is awesome! Thank you for sharing!