Pycroft audio problem

Hey Mycroft

I am still rying to get Mycroft ai to work on a pi 3 b+ with a seeed 2mic pi hat. I have reinstalled picroft 3 times now and everytime I get the same problem with Alsa

I have installed the driver and I know the speaker works (not sure about the mic) and edited the boot file so the card is recognized by alsamixer.

First; I cannot save alsamixer settings after a reboot. I have tried sudo alsamixer and sudo aslactl store, but they do not work.

Second; when Mycroft boots up I get the error message;
Error couldn’t allocate mixer ,Alsa sound error (unable to find mixer cotrol master.0(default)

This is driving me round the bend so thanks for reading and thanks for any replies.


1 Like

Hi there @aaron57 sorry to hear it’s still not going your way.

The alsa error is definitely because it doesn’t have a “default” device set.
How did you go installing pulseaudio like I advised in the previous topic?

It might be an idea just to keep everyone in one topic so we can quickly refer to the history

Let’s try installing pulseaudio and see if that makes a difference.
sudo apt-get install pulseaudio

Yes, I am sorry about the multiple topics.

I have installed pulsaudio and when I open alsamixer, pulsaudio is the default card. I have the option of choosingthe seeed 2mic voicecard, but I can’t make alsa save that as default. Which card should be the default one anyway?

I have opened audio and added
amixer sset ‘Master’ 90% and amixer sset ‘Capture’ 90%
to the bottom of the file.

I know mic and speaker work when tested with arecord -d 10… and aplay…

When I reboot to mycroft the mic is obviously working because the levels change in response to sound , but he does not respond to the wake word and I get no sound when I type a question but I do get a text answer.

Looking to hearing what mycroft has got to say


An update on my picroft audio problem. After playing with mic levels I am now getting the wake sound when I say Hey Mycroft which is great, but I am still not getting any speech from Mr Mycroft.

Also,I am getting this line of red text in the log window:

‘mycroft. client.speech listener:transcribe 186-ERROR-speech recognition could not understand media’

I see in a different post that this maybe something to do with the TTS (text to speech?) engine. What am I to do?

Hey there again @aaron57, thanks for letting us know where you got up to. In order for us to help diagnose in more detail, can you help clarify;

  • When you say you’re not getting any speech from Mycroft, do you mean that the response to questions isn’t being heard? That is, the responses are seen in the CLI, but no sound is output? If so, this indicates an issue with the speaker that is selected on the RPi. What I’d normally do here get you to use alsamixer to select the speaker again but it sounds like that is having no impact. Do you have an asound.rc file? This is an alsamixer configuration file. This is usually in ~/.asoundrc. If not we can have a go at creating one.

The error message;

indicates an issue with Speech to Text transcription, not with Text to Speech. The specific part “could not understand media” indicates that the STT cannot read the input from your microphone.

In conclusion, I think that neither your microphone nor your speaker are correctly selected and that’s the issue we need to try and resolve.

Hi Kathy

That is right. I can verbally ask questions, I get the wake sound, my question is converted to text on the screen and I get an answer in text, But I do not hear the answer. The only sound I get is the wake sound, - a short tone,

I am not that comfortable with the linux command line so I am not sure if I have this asound.rc file.
I have tried 'find / - asound.rc ’ with the result ‘no such file or directory’.

If this is the problem can you tell me how to create/edit this file and what it should contain.

Thanks for your patience


I’m new to Mycroft, but I just had a similar problem. In my case, the speaker volume was set to the lowest setting on every reboot. Telling Mycroft to “set volume to 8” got me sound. Running “bash” wouldn’t hurt either.

Thanks for your reply, but after bash and ‘hey mycroft set volume to 8’ I still have no sound.

I seems so strange…I hear the wake sound but I cannot hear the responses. Its like he thinks I’m too stupid to bother talking to
so sad

So, I am trying out a new RP audio hat (raspiaudio). I have installed the drivers and both the mic and the speakers have been tested and are working. I can say ‘hey mycroft’ and he will respond on the screen but I get no sound at all, not even the wake sound. I really want mycroft to talk to me, what do I do?
Please help

Okay, I have finally got picroft to work…
I ran the ‘mycroft-setup-wizard’ and chose google voicehat audio.
I am not sure exactly made the difference, but I am now a happy mycroftee
Cheers everybody!
So much potential in something so small. Keep up the amazing work.

1 Like

Same issue, this fix worked for me as well… Thanks!

1 Like

Sam issue here. Fix did not work for me.
The mic is working (I can see in the CLI and the listening-sound appears when I say the wake word).
The speaker in general is working too, as it plays the wake sound.
Mycroft understands and answers - but only in the cli! Not via sound!
What can I do?


Do you have the google-aiy-kit? Because if so, i don’t think pulseaudio is supported.

Perhaps you use the paplay command in mycroft.conf as it is now the default. Change it to aplay instead to make use of the alsa asound configuration.