Ps3 Microphone not displaying bars in mycroft cli but mic working outside mycroft

I have setup fresh picroft image with ps3 eye microphone and headphone for speaker, i can confirm that arecord test.wav worked and also test_microphone worked but when used within the mycroft, the mic level is not changing anything as we speak and not detecting the wakeup word and i get the following error message

I fixed the .asoundrc and i can record sounds outside mycroft with just “arecord test.wav” and play “aplay test.wav”

09:33:46.357 - mycroft.skills.settings:_request_my_settings:433 - INFO - getting skill settings from server for WeatherSkill
09:33:46.365 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api mycroft ai
09:33:47.920 - requests.packages.urllib3.connectionpool - DEBUG - api mycroft ai 443 “GET /v1/device/bdec9649-86fe-41a8-aa95-162066b99f0f/skill HTTP/1.1” 200 1138
09:33:47.944 - mycroft.skills.settings:_poll_skill_settings:399 - ERROR - 'value’
09:33:47.948 - mycroft.skills.settings:_poll_skill_settings:400 - ERROR -
Traceback (most recent call last):
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.15-py2.7.egg/mycroft/skills/”, line 388, in _poll_skill_settings
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.15-py2.7.egg/mycroft/skills/”, line 160, in initialize_remote_settings
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.15-py2.7.egg/mycroft/skills/”, line 220, in save_skill_settings
self[field[‘name’]] = field[‘value’]
KeyError: ‘value’

09:54:07.087 - - INFO - Connected
09:54:08.073 - mycroft.client.speech.listener:run:322 - DEBUG - Config has changed, reloading…
09:54:08.575 - mycroft.client.speech.listener:create_wake_word_recognizer:232 - INFO - creating wake word engine
09:54:08.580 - mycroft.client.speech.hotword_factory:create_hotword:256 - INFO - creating hey
09:54:08.868 - mycroft.client.speech.listener:create_wakeup_recognizer:250 - INFO - creating stand up word engine
09:54:08.873 - mycroft.client.speech.hotword_factory:create_hotword:256 - INFO - creating wake up
09:54:09.159 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1):
Expression ‘parameters->channelCount <= maxChans’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 1514
Expression ‘ValidateParameters( inputParameters, hostApi, StreamDirection_In )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2818
Exception in thread Thread-17:
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 810, in __bootstrap_inner
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.15-py2.7.egg/mycroft/client/speech/”, line 54, in run
with self.mic as source:
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.9.15-py2.7.egg/mycroft/client/speech/”, line 113, in enter
input=True, # stream is an input stream
File “/usr/local/lib/python2.7/site-packages/”, line 750, in open
stream = Stream(self, *args, **kwargs)
File “/usr/local/lib/python2.7/site-packages/”, line 441, in init
self._stream =**arguments)
IOError: [Errno -9998] Invalid number of channels

Please help me, i spent hours and hours but could not figure out this microphone issue

@Karthik_Balu you’ve probably already tried this, but have you gone through our audio troubleshooting at:

If so let me know and we’ll see where we should go next.

Kind regards,