PS3 Eye Camera and Ubuntu

Hi! This isn’t exactly a Mycroft question, but since the goal is to run Mycroft I thought I’d see if anyone had run into this problem. I had Pycroft up and running on a Raspberry PI 3 and a PS3 Eye camera, but I wasn’t happy with the performance, so I decided to try it on a desktop while I waited to buy a more powerful SBC. However, Ubuntu won’t pick up sound from the microphones on the PS3 Eye. Video works perfectly, but the microphones don’t , even though it shows up as a microphone in audio control panel.

I tried this:

which recommened adding this line: CARDINFO{driver}==“USB-Audio”, INCLUDE=“usb”, GOTO=“init_end”

to /usr/share/alsa/init/00main which resulted in none of my sound working. So I undid that, and I tried info found at ,

which said to run : $ sudo echo “load-module module-alsa-source device=hw:1,0” >> /etc/pulse/

Which gets me a permission denied error even when using sudo.

Thanks in advance for any ideas you may have!

Hi @khantroll

There are some tips in our audio troubleshooting guide that might help here even though it’s not for Mycroft.

First I’d test the mic to see if it’s being picked up at a lower system level, just not by other applications on your machine. To do this run:
arecord -d 10 -o test.wav
then to play it back:
aplay test.wav

If that doesn’t work I’d try setting your default devices in pulseaudio and give the above test another run.

Hi Gez! I’ll take a look at the troubleshooting guide; I hadn’t seen it.

I tried arecord, but it didn’t pickup sound, even though Pulse had it listed as the default.


1 Like