Precise wakeword not working

I have a wakeword trained and precise-listen works with it and precise-test says it has nearly 100% accuracy, but when I try to load it in Mycroft, it doesn’t ever activate.
I was getting an error where it said it couldn’t read the .pb.params file, but it no longer gives any error, just says it is loading “wake up”.
When I did “mycroft-config edit user”, I had this in the file:

“max_allowed_core_version”: 19.8,
“listener”: {
“wake_word”: “hey-alfred”
“hotwords”: {
“hey-alfred”: {
“module”: “precise”,
“local_model_file”: “/home/aamott/mycroft-core/mycroft-precise/hey-alfred.pb”

I tried downloading the “computer” wakeword before, and that sort of worked (lots of false positives), but that doesn’t even seem to be working now.
Upon taking this out and switching my wakeword via, it began working again, but that still leaves me without this wakeword.
Any help would be appreciated!

Hi we debugged a similar issue earlier this week and that one had a versioning issue. Mycroft is still running precise 0.2.0 while the github project is at 0.3.0 and apparently contains some changes that are not 100% compatible.

You can try to to download a release for your platform and replace the old version with the new (remove ~/.mycroft/precise/precise-engine and replace it with the folder from the release archive).

It is a bit weird that you don’t see any reference to your wake word when loading, it should at least say that it’s either loaded or failed and falling back to hey-mycroft.

Worked great! Thanks!