Pocket sphinx wake word only works occasionally

Sorry if this issue as been dealt with before, but I am having trouble with the wake word. I am on ubuntu 16.04 and 20.04 using pocket sphinx as the listener and Hey Mycroft as the wake word. Every thing else seems to be okay. It only works very occasionally and I am wondering if there is a way of changing the accuracy so that it accepts my voice better.
This is a great project, but quite tricky.

You could try to adjust the threshold option: https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/customizations/wake-word#other-settings

You’re also far better off getting a custom precise word trained than suffering through with pocketsphinx in the long run.

Do you mean I should go back to precise and train the machine somehow?
Can you point me to instructions please,
And thank you


I’m very lost here.
If I run ‘grep avx /proc/cpuinfo’ I get no response which means I cannot use precise for the wake word. is that right?
Here is the relevant section in my mycroct conf file (I think).

// Hotword configurations

  • “hotwords”: {*

  • “hey mycroft”: {*

  •    "module": "precise",*
  •    "phonemes": "HH EY . M AY K R AO F T",*
  •    "threshold": 1e-90,*
  •    "lang": "en-us"*
  •    // Specify custom model via:*
  •    // "local_model_file": "~/.mycroft/precise/models/something.pb"*
  •    // Precise options:*
  •    // "sensitivity": 0.5,  // Higher = more sensitive*
  •    // "trigger_level": 3   // Higher = more delay & less sensitive*
  •    },*
  • “wake up”: {*

  •    "module": "pocketsphinx",*
  •    "phonemes": "HH EY . M AY K R AO F T",*
  •    "threshold": 1e-10,*
  •    "lang": "en-us"*
  •    }*
  • },*
    how do I edit it so it makes pocket sphinx more responsive?

Do you have asimd instruction?
I’ve a RPi 4 which doesn’t have the avx instruction set and I’m using Precise.

Please use the code (image ) when you paste code :slight_smile:

1 Like

Ooops, sorry about the code.
What is asmid instruction, how do I find out if I have it and how does it help?

Same as for the avx instruction.
asimd instruction is similar to avx but for ARM architecture.

I run `grep asimd /proc/cpuinfo and I get nothing in return, so I assume I have to stick with pocket sphinx. Is there any way to get it to work better. I spend half my life saying ‘hey mycroft’ with no result
I tried to put the code in </> but I’m not sure it worked.

What is your hardware?

I’m on a Dell inspiron laptop running ubuntu 16.04

Which model, which CPU?

Dell Inspiron 15
5000 series
Intel® Pentium® CPU 4415U @ 2.30GHz × 4
3.8 GiB